summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/botan/botan-2.17.3-r1.ebuild4
-rw-r--r--dev-libs/botan/botan-2.18.1-r1.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/botan/botan-2.17.3-r1.ebuild b/dev-libs/botan/botan-2.17.3-r1.ebuild
index 2bb63cd2ae79..9900e923b2a8 100644
--- a/dev-libs/botan/botan-2.17.3-r1.ebuild
+++ b/dev-libs/botan/botan-2.17.3-r1.ebuild
@@ -53,6 +53,8 @@ python_check_deps() {
}
src_configure() {
+ python_setup
+
local disable_modules=()
use boost || disable_modules+=( "boost" )
use bindist && disable_modules+=( "ecdsa" )
@@ -112,7 +114,7 @@ src_configure() {
tc-export CC CXX AR
- ./configure.py "${myargs[@]}" || die "configure.py failed"
+ ${EPYTHON} configure.py "${myargs[@]}" || die "configure.py failed with ${EPYTHON}"
}
src_test() {
diff --git a/dev-libs/botan/botan-2.18.1-r1.ebuild b/dev-libs/botan/botan-2.18.1-r1.ebuild
index 5f66e51f3aa3..0e5c78c36a50 100644
--- a/dev-libs/botan/botan-2.18.1-r1.ebuild
+++ b/dev-libs/botan/botan-2.18.1-r1.ebuild
@@ -59,6 +59,8 @@ python_check_deps() {
}
src_configure() {
+ python_setup
+
local disable_modules=(
$(usex boost '' 'boost')
$(usex bindist 'ecdsa' '')
@@ -147,7 +149,7 @@ src_configure() {
tc-export CC CXX AR
- ./configure.py "${myargs[@]}" || die "configure.py failed"
+ ${EPYTHON} configure.py "${myargs[@]}" || die "configure.py failed with ${EPYTHON}"
}
src_test() {