summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/argus/argus-3.0.8.2-r3.ebuild (renamed from net-analyzer/argus/argus-3.0.8.2-r1.ebuild)11
-rw-r--r--net-analyzer/argus/argus-3.0.8.2-r4.ebuild (renamed from net-analyzer/argus/argus-3.0.8.2-r2.ebuild)20
-rw-r--r--net-analyzer/argus/argus-3.0.8.3-r1.ebuild (renamed from net-analyzer/argus/argus-3.0.8.3.ebuild)20
3 files changed, 16 insertions, 35 deletions
diff --git a/net-analyzer/argus/argus-3.0.8.2-r1.ebuild b/net-analyzer/argus/argus-3.0.8.2-r3.ebuild
index 2e662864e3e6..a0f306223745 100644
--- a/net-analyzer/argus/argus-3.0.8.2-r1.ebuild
+++ b/net-analyzer/argus/argus-3.0.8.2-r3.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit autotools eutils user
+
+inherit autotools epatch
DESCRIPTION="network Audit Record Generation and Utilization System"
HOMEPAGE="https://www.qosient.com/argus/"
@@ -14,6 +15,8 @@ KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="debug +libtirpc sasl tcpd"
RDEPEND="
+ acct-group/argus
+ acct-user/argus
net-libs/libnsl:=
net-libs/libpcap
sys-libs/zlib
@@ -22,7 +25,6 @@ RDEPEND="
sasl? ( dev-libs/cyrus-sasl )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
"
-
DEPEND="
${RDEPEND}
>=sys-devel/bison-1.28
@@ -76,11 +78,6 @@ src_install() {
keepdir /var/lib/argus
}
-pkg_preinst() {
- enewgroup argus
- enewuser argus -1 -1 /var/lib/argus argus
-}
-
pkg_postinst() {
elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
elog "possible that the init script will fail to work."
diff --git a/net-analyzer/argus/argus-3.0.8.2-r2.ebuild b/net-analyzer/argus/argus-3.0.8.2-r4.ebuild
index 807aab798e06..3ca4a4b18ff6 100644
--- a/net-analyzer/argus/argus-3.0.8.2-r2.ebuild
+++ b/net-analyzer/argus/argus-3.0.8.2-r4.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools user
+
+inherit autotools
DESCRIPTION="network Audit Record Generation and Utilization System"
HOMEPAGE="https://openargus.org/"
@@ -14,6 +15,8 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="debug +libtirpc sasl tcpd"
RDEPEND="
+ acct-group/argus
+ acct-user/argus
net-libs/libnsl:=
net-libs/libpcap
sys-libs/zlib
@@ -22,9 +25,8 @@ RDEPEND="
sasl? ( dev-libs/cyrus-sasl )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
"
-
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=sys-devel/bison-1.28
>=sys-devel/flex-2.4.6
"
@@ -37,11 +39,6 @@ PATCHES=(
)
S=${WORKDIR}/${P/_rc/.rc.}
-pkg_setup() {
- enewgroup argus
- enewuser argus -1 -1 /var/lib/argus argus
-}
-
src_prepare() {
find . -type f -execdir chmod +w {} \; #561360
sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
@@ -82,11 +79,6 @@ src_install() {
keepdir /var/lib/argus
}
-pkg_preinst() {
- enewgroup argus
- enewuser argus -1 -1 /var/lib/argus argus
-}
-
pkg_postinst() {
elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
elog "possible that the init script will fail to work."
diff --git a/net-analyzer/argus/argus-3.0.8.3.ebuild b/net-analyzer/argus/argus-3.0.8.3-r1.ebuild
index 8092871dded2..bc999ce39081 100644
--- a/net-analyzer/argus/argus-3.0.8.3.ebuild
+++ b/net-analyzer/argus/argus-3.0.8.3-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools user
+
+inherit autotools
DESCRIPTION="network Audit Record Generation and Utilization System"
HOMEPAGE="https://openargus.org/"
@@ -14,6 +15,8 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="debug sasl tcpd"
RDEPEND="
+ acct-group/argus
+ acct-user/argus
net-libs/libnsl:=
net-libs/libpcap
net-libs/libtirpc
@@ -21,9 +24,8 @@ RDEPEND="
sasl? ( dev-libs/cyrus-sasl )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
"
-
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=sys-devel/bison-1.28
>=sys-devel/flex-2.4.6
"
@@ -36,11 +38,6 @@ PATCHES=(
)
S=${WORKDIR}/${P/_rc/.rc.}
-pkg_setup() {
- enewgroup argus
- enewuser argus -1 -1 /var/lib/argus argus
-}
-
src_prepare() {
find . -type f -execdir chmod +w {} \; #561360
sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
@@ -84,11 +81,6 @@ src_install() {
keepdir /var/lib/argus
}
-pkg_preinst() {
- enewgroup argus
- enewuser argus -1 -1 /var/lib/argus argus
-}
-
pkg_postinst() {
elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
elog "possible that the init script will fail to work."