summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libnsl/Manifest1
-rw-r--r--net-libs/libnsl/libnsl-1.3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libnsl/Manifest b/net-libs/libnsl/Manifest
index f6db6f19194a..0adf5f26e283 100644
--- a/net-libs/libnsl/Manifest
+++ b/net-libs/libnsl/Manifest
@@ -1 +1,2 @@
DIST libnsl-1.2.0.tar.gz 209188 BLAKE2B 4249cfbf0b5391790f5e5f81e4eb0be963e5fdc0c32a9400d4128e717d93da49f8751caf8de3bb4ba1a23b8670a0e4f8e750f38f4612dd0cc97db4c157421a06 SHA512 30115aa679a04ad01f55cff9dd1890b4c41c730a9bac2adab5add9ae03a0b4687c5f4b6e3b8652ecbb074eefac8faee3f1f13ea60d42cf4432db8a575ca72cd8
+DIST libnsl-1.3.0.tar.gz 95645 BLAKE2B d5116c2837a7ed5d5916d571d2e5deaf733b2e3e4401c2ebb0ec253d2755c2dc169139ea64756bd4ab28e3107f9ff1dcdd5ef6657828862a95ca18f2f145e3b3 SHA512 ce75ee9e54f1bdd2b31886e8157ff5f654511c3da017e0d9f8d0da6a2a9f9a78ff2e5f72cfb7ce3a23065f57337db51e3c8842a7e990350a62612018f4960342
diff --git a/net-libs/libnsl/libnsl-1.3.0.ebuild b/net-libs/libnsl/libnsl-1.3.0.ebuild
new file mode 100644
index 000000000000..1c8cb717c768
--- /dev/null
+++ b/net-libs/libnsl/libnsl-1.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Public client interface for NIS(YP) and NIS+ in a IPv6 ready version"
+HOMEPAGE="https://github.com/thkukuk/libnsl"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/2"
+LICENSE="LGPL-2.1+"
+
+# Stabilize together with glibc-2.26!
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="
+ >=net-libs/libtirpc-1.0.2-r1[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<sys-libs/glibc-2.26
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}