summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/prettytable/prettytable-0.7.2-r1.ebuild5
1 files changed, 1 insertions, 4 deletions
diff --git a/dev-python/prettytable/prettytable-0.7.2-r1.ebuild b/dev-python/prettytable/prettytable-0.7.2-r1.ebuild
index 7aaaccc30518..007312c8738d 100644
--- a/dev-python/prettytable/prettytable-0.7.2-r1.ebuild
+++ b/dev-python/prettytable/prettytable-0.7.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
inherit distutils-r1
@@ -17,9 +17,6 @@ KEYWORDS="~alpha amd64 arm64 hppa ~ia64 ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
python_test() {
"${PYTHON}" prettytable_test.py || die "tests failed under ${EPYTHON}"
}