summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.12.ebuild2
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r3.ebuild2
-rw-r--r--eclass/flag-o-matic.eclass72
-rwxr-xr-xeclass/tests/flag-o-matic.sh2
-rw-r--r--media-sound/aeolus/aeolus-0.9.7.ebuild2
-rw-r--r--media-sound/jaaa/jaaa-0.9.2.ebuild2
-rw-r--r--net-print/cups/cups-2.2.13.ebuild2
-rw-r--r--sci-mathematics/agda/agda-2.4.2.5-r2.ebuild2
-rw-r--r--sci-mathematics/agda/agda-2.5.2-r1.ebuild2
-rw-r--r--sci-mathematics/agda/agda-2.5.2-r2.ebuild2
-rw-r--r--sys-devel/autogen/autogen-5.18.16-r1.ebuild2
11 files changed, 68 insertions, 24 deletions
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.12.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.12.ebuild
index 5b143d6a7185..7ebdcef350b1 100644
--- a/app-admin/system-config-printer/system-config-printer-1.5.12.ebuild
+++ b/app-admin/system-config-printer/system-config-printer-1.5.12.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://github.com/OpenPrinting/system-config-printer"
SRC_URI="https://github.com/OpenPrinting/${PN}/releases/download/${PV}/${P}.tar.xz"
LICENSE="GPL-2+"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc x86"
SLOT="0"
IUSE="doc gnome-keyring policykit"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r3.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r3.ebuild
index eae354404ea6..0a8419258669 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r3.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r3.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/cyrusimap/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD-with-attribution"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="authdaemond berkdb gdbm kerberos ldapdb libressl openldap mysql pam postgres sample selinux sqlite srp ssl static-libs urandom"
CDEPEND="
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index f882b09d6219..0aec22c83f2c 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -441,29 +441,63 @@ test-flag-PROG() {
# 'type' needs a binary name
type -p ${comp[0]} >/dev/null || return 1
+ # Set up test file.
+ local in_src in_ext cmdline_extra=()
+ case "${lang}" in
+ # compiler/assembler only
+ c)
+ in_ext='.c'
+ in_src='int main(void) { return 0; }'
+ cmdline_extra+=(-xc -c)
+ ;;
+ c++)
+ in_ext='.cc'
+ in_src='int main(void) { return 0; }'
+ cmdline_extra+=(-xc++ -c)
+ ;;
+ f77)
+ in_ext='.f'
+ # fixed source form
+ in_src=' end'
+ cmdline_extra+=(-xf77 -c)
+ ;;
+ f95)
+ in_ext='.f90'
+ in_src='end'
+ cmdline_extra+=(-xf95 -c)
+ ;;
+
+ # C compiler/assembler/linker
+ c+ld)
+ in_ext='.c'
+ in_src='int main(void) { return 0; }'
+ cmdline_extra+=(-xc)
+ ;;
+ esac
+ local test_in=${T}/test-flag-${comp}.${lang}
+ local test_out=${T}/test-flag-${comp}.exe
+
+ printf "%s\n" "${in_src}" > "${test_in}" || return 1
+
local cmdline=(
"${comp[@]}"
# Clang will warn about unknown gcc flags but exit 0.
# Need -Werror to force it to exit non-zero.
-Werror
- # Use -c so we can test the assembler as well.
- -c -o /dev/null
+ "$@"
+ # -x<lang> options need to go before first source file
+ "${cmdline_extra[@]}"
+
+ "${test_in}" -o "${test_out}"
)
- if "${cmdline[@]}" -x${lang} - </dev/null &>/dev/null ; then
- cmdline+=( "$@" -x${lang} - )
- else
- # XXX: what's the purpose of this? does it even work with
- # any compiler?
- cmdline+=( "$@" -c -o /dev/null /dev/null )
- fi
- if ! "${cmdline[@]}" </dev/null &>/dev/null; then
+ if ! "${cmdline[@]}" &>/dev/null; then
# -Werror makes clang bail out on unused arguments as well;
# try to add -Qunused-arguments to work-around that
# other compilers don't support it but then, it's failure like
# any other
cmdline+=( -Qunused-arguments )
- "${cmdline[@]}" </dev/null &>/dev/null
+ "${cmdline[@]}" &>/dev/null
fi
}
@@ -491,6 +525,12 @@ test-flag-F77() { test-flag-PROG "F77" f77 "$@"; }
# Returns shell true if <flag> is supported by the Fortran 90 compiler, else returns shell false.
test-flag-FC() { test-flag-PROG "FC" f95 "$@"; }
+# @FUNCTION: test-flag-CCLD
+# @USAGE: <flag>
+# @DESCRIPTION:
+# Returns shell true if <flag> is supported by the C compiler and linker, else returns shell false.
+test-flag-CCLD() { test-flag-PROG "CC" c+ld "$@"; }
+
test-flags-PROG() {
local comp=$1
local flags=()
@@ -548,6 +588,12 @@ test-flags-F77() { test-flags-PROG "F77" "$@"; }
# Returns shell true if <flags> are supported by the Fortran 90 compiler, else returns shell false.
test-flags-FC() { test-flags-PROG "FC" "$@"; }
+# @FUNCTION: test-flags-CCLD
+# @USAGE: <flags>
+# @DESCRIPTION:
+# Returns shell true if <flags> are supported by the C compiler and default linker, else returns shell false.
+test-flags-CCLD() { test-flags-PROG "CCLD" "$@"; }
+
# @FUNCTION: test-flags
# @USAGE: <flags>
# @DESCRIPTION:
@@ -576,9 +622,7 @@ strip-unsupported-flags() {
export CXXFLAGS=$(test-flags-CXX ${CXXFLAGS})
export FFLAGS=$(test-flags-F77 ${FFLAGS})
export FCFLAGS=$(test-flags-FC ${FCFLAGS})
- # note: this does not verify the linker flags but it is enough
- # to strip invalid C flags which are much more likely, #621274
- export LDFLAGS=$(test-flags-CC ${LDFLAGS})
+ export LDFLAGS=$(test-flags-CCLD ${LDFLAGS})
}
# @FUNCTION: get-flag
diff --git a/eclass/tests/flag-o-matic.sh b/eclass/tests/flag-o-matic.sh
index 7c078499d70c..90eaf3a6ffb0 100755
--- a/eclass/tests/flag-o-matic.sh
+++ b/eclass/tests/flag-o-matic.sh
@@ -8,7 +8,7 @@ inherit flag-o-matic
CFLAGS="-a -b -c=1 --param l1-cache-size=32"
CXXFLAGS="-x -y -z=2"
-LDFLAGS="-l -m -n=3"
+LDFLAGS="-l -m -n=3 -Wl,--remove-me"
ftend() {
local ret=$?
local msg="Failed; flags are:"
diff --git a/media-sound/aeolus/aeolus-0.9.7.ebuild b/media-sound/aeolus/aeolus-0.9.7.ebuild
index 362372efee83..d67d9e69d32f 100644
--- a/media-sound/aeolus/aeolus-0.9.7.ebuild
+++ b/media-sound/aeolus/aeolus-0.9.7.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
BDEPEND="
diff --git a/media-sound/jaaa/jaaa-0.9.2.ebuild b/media-sound/jaaa/jaaa-0.9.2.ebuild
index 0718e1990142..b6575ea56713 100644
--- a/media-sound/jaaa/jaaa-0.9.2.ebuild
+++ b/media-sound/jaaa/jaaa-0.9.2.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE=""
CDEPEND="
diff --git a/net-print/cups/cups-2.2.13.ebuild b/net-print/cups/cups-2.2.13.ebuild
index b6b538b9e4f7..1d9325a6964f 100644
--- a/net-print/cups/cups-2.2.13.ebuild
+++ b/net-print/cups/cups-2.2.13.ebuild
@@ -21,7 +21,7 @@ if [[ ${PV} == *9999 ]]; then
else
#SRC_URI="https://github.com/apple/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI="https://github.com/apple/cups/releases/download/v${PV}/${P}-source.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~m68k-mint"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~m68k-mint"
fi
DESCRIPTION="The Common Unix Printing System"
diff --git a/sci-mathematics/agda/agda-2.4.2.5-r2.ebuild b/sci-mathematics/agda/agda-2.4.2.5-r2.ebuild
index b958c29c5423..634862b133ad 100644
--- a/sci-mathematics/agda/agda-2.4.2.5-r2.ebuild
+++ b/sci-mathematics/agda/agda-2.4.2.5-r2.ebuild
@@ -47,7 +47,7 @@ RDEPEND+="
emacs? ( >=app-editors/emacs-23.1:*
app-emacs/haskell-mode )
"
-PDEPEND="stdlib? ( =sci-mathematics/agda-stdlib-${PV} )"
+PDEPEND="stdlib? ( ~sci-mathematics/agda-stdlib-${PV} )"
DEPEND="${RDEPEND}
dev-haskell/alex
>=dev-haskell/cabal-1.16.0
diff --git a/sci-mathematics/agda/agda-2.5.2-r1.ebuild b/sci-mathematics/agda/agda-2.5.2-r1.ebuild
index d5d805f48bae..9bc509d3579c 100644
--- a/sci-mathematics/agda/agda-2.5.2-r1.ebuild
+++ b/sci-mathematics/agda/agda-2.5.2-r1.ebuild
@@ -66,7 +66,7 @@ RDEPEND+="
emacs? ( >=app-editors/emacs-23.1:*
app-emacs/haskell-mode )
"
-PDEPEND="stdlib? ( =sci-mathematics/agda-stdlib-${MY_GENTOO_AGDA_STDLIB_V} )"
+PDEPEND="stdlib? ( ~sci-mathematics/agda-stdlib-${MY_GENTOO_AGDA_STDLIB_V} )"
DEPEND="${RDEPEND}
dev-haskell/alex
>=dev-haskell/cabal-1.22.2.0
diff --git a/sci-mathematics/agda/agda-2.5.2-r2.ebuild b/sci-mathematics/agda/agda-2.5.2-r2.ebuild
index 2f77831b0722..c5ee1f841665 100644
--- a/sci-mathematics/agda/agda-2.5.2-r2.ebuild
+++ b/sci-mathematics/agda/agda-2.5.2-r2.ebuild
@@ -66,7 +66,7 @@ RDEPEND+="
emacs? ( >=app-editors/emacs-23.1:*
app-emacs/haskell-mode )
"
-PDEPEND="stdlib? ( =sci-mathematics/agda-stdlib-${MY_GENTOO_AGDA_STDLIB_V} )"
+PDEPEND="stdlib? ( ~sci-mathematics/agda-stdlib-${MY_GENTOO_AGDA_STDLIB_V} )"
DEPEND="${RDEPEND}
dev-haskell/alex
>=dev-haskell/cabal-1.22.2.0
diff --git a/sys-devel/autogen/autogen-5.18.16-r1.ebuild b/sys-devel/autogen/autogen-5.18.16-r1.ebuild
index 2630b791b5ae..9ff17a72e6b3 100644
--- a/sys-devel/autogen/autogen-5.18.16-r1.ebuild
+++ b/sys-devel/autogen/autogen-5.18.16-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="libopts static-libs"
RDEPEND=">=dev-scheme/guile-2.0:=