summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/putty/files/putty-0.77-nogssapi.patch18
-rw-r--r--net-misc/putty/putty-0.77-r3.ebuild (renamed from net-misc/putty/putty-0.77-r2.ebuild)5
2 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/putty/files/putty-0.77-nogssapi.patch b/net-misc/putty/files/putty-0.77-nogssapi.patch
new file mode 100644
index 000000000000..84d36e1849e0
--- /dev/null
+++ b/net-misc/putty/files/putty-0.77-nogssapi.patch
@@ -0,0 +1,18 @@
+Define NO_GSSAPI when -DPUTTY_GSSAPI=OFF
+
+Previously it would only be defined if -DPUTTY_GSSAPI=DYNAMIC and libdl is
+not found on the system. Setting -DPUTTY_GSSAPI=OFF on systems with glibc
+2.33 and earlier causes a build failure, because libdl is not linked in.
+
+Bug: https://bugs.gentoo.org/873355
+--- a/cmake/platforms/unix.cmake
++++ b/cmake/platforms/unix.cmake
+@@ -105,6 +105,8 @@
+ "Could not find libdl -- cannot provide dynamic GSSAPI support")
+ set(NO_GSSAPI ON)
+ endif()
++else()
++ set(NO_GSSAPI ON)
+ endif()
+
+ if(PUTTY_GSSAPI STREQUAL STATIC)
diff --git a/net-misc/putty/putty-0.77-r2.ebuild b/net-misc/putty/putty-0.77-r3.ebuild
index f3873e1fcf7f..737dcfe68966 100644
--- a/net-misc/putty/putty-0.77-r2.ebuild
+++ b/net-misc/putty/putty-0.77-r3.ebuild
@@ -44,6 +44,11 @@ REQUIRED_USE="
gtk2? ( gtk )
"
+PATCHES=(
+ # Bug #873355
+ "${FILESDIR}"/putty-0.77-nogssapi.patch
+)
+
src_unpack() {
[[ ${PV} == *9999 ]] && git-r3_src_unpack
default