summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/dnsproxy/dnsproxy-1.17-r1.ebuild (renamed from net-proxy/dnsproxy/dnsproxy-1.17.ebuild)13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-proxy/dnsproxy/dnsproxy-1.17.ebuild b/net-proxy/dnsproxy/dnsproxy-1.17-r1.ebuild
index d39f3894720d..a9d22d44e75e 100644
--- a/net-proxy/dnsproxy/dnsproxy-1.17.ebuild
+++ b/net-proxy/dnsproxy/dnsproxy-1.17-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit flag-o-matic
+EAPI=8
+
+inherit autotools flag-o-matic
DESCRIPTION="The dnsproxy daemon is a proxy for DNS queries"
HOMEPAGE="https://www.wolfermann.org/dnsproxy.html"
@@ -18,10 +19,18 @@ DEPEND="
RDEPEND="
${DEPEND}
"
+
PATCHES=(
"${FILESDIR}"/${PN}-1.16-include.patch
)
+src_prepare() {
+ default
+
+ # bug #900288
+ eautoreconf
+}
+
src_compile() {
# https://github.com/awaw/dnsproxy/commit/7eba35568c87a21a668722b3b04c113e9160e789
append-cppflags -D_GNU_SOURCE