summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/doublex/Manifest1
-rw-r--r--dev-python/doublex/doublex-1.9.6.1.ebuild42
-rw-r--r--dev-python/doublex/metadata.xml8
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/doublex/Manifest b/dev-python/doublex/Manifest
index bf5a43b36bb0..4c74d171f9cc 100644
--- a/dev-python/doublex/Manifest
+++ b/dev-python/doublex/Manifest
@@ -1,2 +1,3 @@
DIST doublex-1.9.2.tar.gz 80246 BLAKE2B 7fc1c4e6d117bee13e7125b634293aa7c9d1016c9cd5201f047143bcb1fae1e9607bf0a030cbaa2d6eb930474babe29aaf244433aba57ae4325a3a43af2fdf56 SHA512 0278f756930b0d5c3da676e3908ccc17b919c14f740aace3002f5117fa341ac52fe16fdaa2c3b36029757dd1dc2f36d8d35cdc8664fcfdbcafd4809d2fc969b0
DIST doublex-1.9.5.1.tar.gz 80508 BLAKE2B 3c3e233bbe4fcc3a122430bfb826ab9824d41472e80802f0e6d345da83cbe97bb33912a831bead550299942b0087063e86839f6bf3a29a08164b6e3bf641f437 SHA512 498e8a8076ed7d3585aae7a20edf54d4143e6875cd8e7af3b47f9f9cfc612a5217d7877092c2af7f1ac80c7aad7be89946671a836fc5817de06ec541c0cb1e06
+DIST python-doublex-1.9.6.1.gh.tar.gz 81848 BLAKE2B 34aa108ba12f34f18f7a7b3d12fd2a539736d95097fd3ecf5344fdac551b16717d5348da1c6e2e10e19878b82de7e9195b9bd17d526156bc13e0ad2fd789b23e SHA512 c9779c5fcde43af653c2131894da44a878acf2cc81d53f6ab89a6fde071827a22aa97ec5a51561ad8861a98623d38c75f184be6234a6a5323c52e8e538c66710
diff --git a/dev-python/doublex/doublex-1.9.6.1.ebuild b/dev-python/doublex/doublex-1.9.6.1.ebuild
new file mode 100644
index 000000000000..b3294eb65659
--- /dev/null
+++ b/dev-python/doublex/doublex-1.9.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-doublex-${PV}
+DESCRIPTION="Python test doubles"
+HOMEPAGE="
+ https://github.com/davidvilla/python-doublex/
+ https://pypi.org/project/doublex/
+"
+SRC_URI="
+ https://github.com/davidvilla/python-doublex/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/pyhamcrest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/data_files/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -o 'python_files=*_tests.py'
+}
diff --git a/dev-python/doublex/metadata.xml b/dev-python/doublex/metadata.xml
index a81fcaafc2cb..fb140d4056b7 100644
--- a/dev-python/doublex/metadata.xml
+++ b/dev-python/doublex/metadata.xml
@@ -1,9 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!--maintainer-needed-->
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
<upstream>
+ <remote-id type="github">davidvilla/python-doublex</remote-id>
<remote-id type="pypi">doublex</remote-id>
- <remote-id type="bitbucket">DavidVilla/python-doublex</remote-id>
</upstream>
</pkgmetadata>