summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jinja/Manifest2
-rw-r--r--dev-python/jinja/jinja-3.0.3.ebuild52
-rw-r--r--dev-python/jinja/jinja-3.1.0.ebuild52
3 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
index 9d7b28b760f1..592c3324db60 100644
--- a/dev-python/jinja/Manifest
+++ b/dev-python/jinja/Manifest
@@ -1,4 +1,2 @@
DIST jinja-2.11.3.tar.gz 258057 BLAKE2B 4735464d044718ce1e6b2663ecb1b238b38fbf0f37ed683257775fe9e853186c089b98494209e511be5aa96bf6df8f6d472be132b6184a7d9213e182099c0433 SHA512 f8e2951edf780d7b44ac74d36579c89b0a5c076b4250faf643ae7e3ff6a431fedaabed640e5efb496cda1a79a4057bf312ae652484c8d4631d521689eb0adbc1
-DIST jinja-3.0.3.tar.gz 273634 BLAKE2B 3f72840f3f895471896b918b0d3173aa7b40a077fe78a014064e66ac74c3d1ef1ae811723a84ea56d32edde23ee26ab6091bd5ce7ee4e46a9693f34d2538b491 SHA512 8a364620a4660add0593f4b252a2f20423aa3017193dffe6e8aa80710444da0cae5e6c4b77247d39f33e90185f475714fb892f6b5f01d3055a88b0f669a748be
-DIST jinja-3.1.0.tar.gz 271851 BLAKE2B de55a518aa63e3c6ca88bd107709172f73fcb9419c75254b2c23c531b598af7860a303e7da6e61f03cf18edf6935c92f5c12c8b91a7f4eb955c64f472a506b02 SHA512 1bd75c752f8e1c45f05f881598c257a6a357658892307e1352dd4752f45ede9b23f0ce3c16909e1885243199c2b845357c3ea33af8d6848fe346c29eeaf22b60
DIST jinja-3.1.1.tar.gz 272001 BLAKE2B 4787ee89d7e10cea24d3bf2810e391d5c17c00ffee8fd2f9244a9e24b219bc126e4111cc6b788107cbc07dd96732a2d1fc51dd87506545dc8beb7fdce5cd89b1 SHA512 285b3a2e09fbf891ce1d18e2692e400a9fe9d8968a36be50229972d9bdbb590bbea099cd26443de0fbe5ed7a2c6419eb211bfdac15c27a61b8db903e88855478
diff --git a/dev-python/jinja/jinja-3.0.3.ebuild b/dev-python/jinja/jinja-3.0.3.ebuild
deleted file mode 100644
index 2fb8cc8d12ee..000000000000
--- a/dev-python/jinja/jinja-3.0.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="https://jinja.palletsprojects.com/ https://pypi.org/project/Jinja2/"
-# pypi tarball is missing tests
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-issues \
- dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-# XXX: handle Babel better?
-
-src_prepare() {
- # avoid unnecessary dep on extra sphinxcontrib modules
- sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
-
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}
diff --git a/dev-python/jinja/jinja-3.1.0.ebuild b/dev-python/jinja/jinja-3.1.0.ebuild
deleted file mode 100644
index 008e162474da..000000000000
--- a/dev-python/jinja/jinja-3.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="https://jinja.palletsprojects.com/ https://pypi.org/project/Jinja2/"
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-issues \
- dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-# XXX: handle Babel better?
-
-src_prepare() {
- # avoid unnecessary dep on extra sphinxcontrib modules
- sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
-
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}