summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycountry/pycountry-24.6.1.ebuild2
-rw-r--r--eclass/flag-o-matic.eclass4
2 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pycountry/pycountry-24.6.1.ebuild b/dev-python/pycountry/pycountry-24.6.1.ebuild
index 73fa6a875523..0a7638a91e9a 100644
--- a/dev-python/pycountry/pycountry-24.6.1.ebuild
+++ b/dev-python/pycountry/pycountry-24.6.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index ecac452aa0ef..c6b1ad80e12e 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -129,6 +129,10 @@ _setup-allowed-flags() {
# needed for arm64 (and in particular SCS)
-ffixed-x18
+ # needed for riscv (to prevent unaligned vector access)
+ # See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=115789
+ -mstrict-align -mvector-strict-align
+
# gcc 4.5
-mno-fma4 -mno-movbe -mno-xop -mno-lwp
# gcc 4.6