summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flask-cors/Manifest1
-rw-r--r--dev-python/flask-cors/flask-cors-4.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flask-cors/Manifest b/dev-python/flask-cors/Manifest
index b4296a2b5d2d..5e32faa5a455 100644
--- a/dev-python/flask-cors/Manifest
+++ b/dev-python/flask-cors/Manifest
@@ -1 +1,2 @@
DIST flask-cors-3.0.10.gh.tar.gz 31012 BLAKE2B 2e546518c8183dfca32308ef0f7d8f503c75ff62302d11ac0dc315f7c6760fa3e9064477216fd8c2cd290b0a280e6c45c35cf2cce3cfdffe141edab7beca1c8a SHA512 4471e94aea92700185a6fca37f01d61b9b966754f206eb6211813fb8c82fc0d219597e3df80e9d80b68663931ec561ca209fe23afa0142345fb75beacf3adc4e
+DIST flask-cors-4.0.0.gh.tar.gz 31586 BLAKE2B ac3713a08108a621fb0150039a2c40b87a3331084223ec73fb6cf76444e4a7681350a01f18f507b0ee942f01731c289e44950d99412373e7c889beaffa116513 SHA512 04f163d646d2f5fc96b397a3d52ad0e6b99ae6caaec67855e05b4330a323d1b28ab4d624000cbce9a897dba8a00317828e7056537454d1bb7febfcdddd37096d
diff --git a/dev-python/flask-cors/flask-cors-4.0.0.ebuild b/dev-python/flask-cors/flask-cors-4.0.0.ebuild
new file mode 100644
index 000000000000..59970129051b
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/corydolphin/flask-cors.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/corydolphin/flask-cors/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="A Flask extension for Cross Origin Resource Sharing (CORS)"
+HOMEPAGE="
+ https://github.com/corydolphin/flask-cors/
+ https://pypi.org/project/Flask-Cors/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-httpdomain