summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-3.0.6.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 70307cc851f1..68b955f0b96b 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,2 +1,3 @@
DIST werkzeug-3.0.4.tar.gz 803966 BLAKE2B 56e992c61ed977a677ae4ca403adfb335457df2f096eed3589d74f5539282b144e70895e4d403c9fb72621bc145c91315fab0d3ddca5afcc0040c0e582cf05ec SHA512 40ca7a6c54ba5593a854d6fda6c6b0fed08f03aa970ac83c86aa16b434b6f24f204ca425a0fae3f42610ce6e7ff9220224cc927018a7181d673b48b71b848422
DIST werkzeug-3.0.5.tar.gz 804673 BLAKE2B f094c5efe6a38ed74e571aead1c0981594351625a5c93fd17e6cfb4cba8135d08c5222b47ca4aa688436418f0dd6a00b1a7a354f0ee80f0a7607073883ca50ec SHA512 83db714067fcc29339b9fbdd4d20f849d7e4c0ce5f67e222241f3a3948204ff58d2bca97058b6f5e2aaa99328fa5ae5c68d09496f62c8095fa024f2d4532f9d8
+DIST werkzeug-3.0.6.tar.gz 805170 BLAKE2B 7aa02e3e979d9375ec676d02f43738b96410fc3dddf60ca96fc9709790caa47e590952e7675f9226af9f8111271463e82a7069d0ed6e8e672188bc824d3d04a8 SHA512 500f47e13546a3d0ce3a41f21157649571ea70b332ca22758bad939cb42aee4d1b58b64cecc4ed83a857ad466f37de8256cf7b53ad28e5fe0fd353455df3639b
diff --git a/dev-python/werkzeug/werkzeug-3.0.6.ebuild b/dev-python/werkzeug/werkzeug-3.0.6.ebuild
new file mode 100644
index 000000000000..192a5e46f8aa
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-3.0.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xprocess-1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/pallets/werkzeug/issues/2875
+ "${FILESDIR}/${PN}-3.0.2-pytest-xprocess-1.patch"
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # RequestRedirect class started incidentally being tested
+ # with pytest-8, though the test isn't prepared for that
+ # https://github.com/pallets/werkzeug/issues/2845
+ 'tests/test_exceptions.py::test_response_body[RequestRedirect]'
+ )
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xprocess -p timeout tests
+}