summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/kitty/kitty-0.27.1.ebuild3
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/x11-terms/kitty/kitty-0.27.1.ebuild b/x11-terms/kitty/kitty-0.27.1.ebuild
index 295c1c9a2500..c2975dd65e11 100644
--- a/x11-terms/kitty/kitty-0.27.1.ebuild
+++ b/x11-terms/kitty/kitty-0.27.1.ebuild
@@ -117,7 +117,8 @@ src_prepare() {
src_compile() {
tc-export CC
- local -x GOFLAGS="-buildmode=pie -p=$(makeopts_jobs) -v -x"
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local conf=(
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 707ea2a4a999..f07a85ea74e6 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -117,7 +117,8 @@ src_prepare() {
src_compile() {
tc-export CC
- local -x GOFLAGS="-buildmode=pie -p=$(makeopts_jobs) -v -x"
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local conf=(