summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/mldonkey/mldonkey-3.1.5-r1.ebuild5
-rw-r--r--net-p2p/mldonkey/mldonkey-3.1.6-r1.ebuild5
-rw-r--r--net-p2p/mldonkey/mldonkey-3.1.6.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/net-p2p/mldonkey/mldonkey-3.1.5-r1.ebuild b/net-p2p/mldonkey/mldonkey-3.1.5-r1.ebuild
index 118e1cfae15e..2f99a446acca 100644
--- a/net-p2p/mldonkey/mldonkey-3.1.5-r1.ebuild
+++ b/net-p2p/mldonkey/mldonkey-3.1.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -27,6 +27,8 @@ RDEPEND="dev-lang/perl
DEPEND="${RDEPEND}
>=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RESTRICT="!ocamlopt? ( strip )"
+
MLUSER="p2p"
pkg_setup() {
@@ -111,7 +113,6 @@ src_compile() {
src_install() {
local myext=""
use ocamlopt || myext=".byte"
- use ocamlopt || export STRIP_MASK="*/bin/*"
if ! use guionly; then
for i in mlnet mld_hash get_range copysources subconv; do
newbin $i$myext $i
diff --git a/net-p2p/mldonkey/mldonkey-3.1.6-r1.ebuild b/net-p2p/mldonkey/mldonkey-3.1.6-r1.ebuild
index 242b41314223..a92fc8ae4722 100644
--- a/net-p2p/mldonkey/mldonkey-3.1.6-r1.ebuild
+++ b/net-p2p/mldonkey/mldonkey-3.1.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -29,6 +29,8 @@ RDEPEND="dev-lang/perl
DEPEND="${RDEPEND}
>=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RESTRICT="!ocamlopt? ( strip )"
+
MLUSER="p2p"
pkg_setup() {
@@ -113,7 +115,6 @@ src_compile() {
src_install() {
local myext=""
use ocamlopt || myext=".byte"
- use ocamlopt || export STRIP_MASK="*/bin/*"
if ! use guionly; then
for i in mlnet mld_hash get_range copysources subconv; do
newbin $i$myext $i
diff --git a/net-p2p/mldonkey/mldonkey-3.1.6.ebuild b/net-p2p/mldonkey/mldonkey-3.1.6.ebuild
index 861c8017b3ed..06defbcd139a 100644
--- a/net-p2p/mldonkey/mldonkey-3.1.6.ebuild
+++ b/net-p2p/mldonkey/mldonkey-3.1.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -27,6 +27,8 @@ RDEPEND="dev-lang/perl
DEPEND="${RDEPEND}
>=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RESTRICT="!ocamlopt? ( strip )"
+
MLUSER="p2p"
pkg_setup() {
@@ -109,7 +111,6 @@ src_compile() {
src_install() {
local myext=""
use ocamlopt || myext=".byte"
- use ocamlopt || export STRIP_MASK="*/bin/*"
if ! use guionly; then
for i in mlnet mld_hash get_range copysources subconv; do
newbin $i$myext $i