summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/asteval/Manifest1
-rw-r--r--dev-python/asteval/asteval-0.9.29.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/asteval/Manifest b/dev-python/asteval/Manifest
index 5e4155821b71..19cb9aa71a56 100644
--- a/dev-python/asteval/Manifest
+++ b/dev-python/asteval/Manifest
@@ -1 +1,2 @@
DIST asteval-0.9.28.gh.tar.gz 39784 BLAKE2B 99c74b7d9f01de07dc568a5276852e66dd6c520c45af91b9471bc6f9485ac50bc20bc96df804188a610bac01e8e34534e8bb157784afd6b1799ca97280e4c5ed SHA512 108652594a0eaaf009b8652ced9000ef7454d8f33fe844e74fb1dd78a2ead42a60d5ba68845c8d9c9d8570a70b5958519a6350d77c66257a7fa18de23802c3b0
+DIST asteval-0.9.29.gh.tar.gz 40010 BLAKE2B 1e2570afefc4ca0abd2a19d3498479a947e1634a550bd14f2efe813e00f3ec37b9f0e417616878a087a110d92474a626ba9b2972f8585f528fa492b99b758f03 SHA512 5afd7fe5349b5611112fc15a980f435e359c5fd81ece77041aed84566703f4621ac360dda2f133f0342a8eefe755820f7544fd5eb8195462cc05281ed0eba5dc
diff --git a/dev-python/asteval/asteval-0.9.29.ebuild b/dev-python/asteval/asteval-0.9.29.ebuild
new file mode 100644
index 000000000000..3d74a230e35d
--- /dev/null
+++ b/dev-python/asteval/asteval-0.9.29.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Evaluator of Python expression using ast module"
+HOMEPAGE="
+ https://newville.github.io/asteval/
+ https://github.com/newville/asteval/
+ https://pypi.org/project/asteval/
+"
+SRC_URI="
+ https://github.com/newville/asteval/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest -o addopts=
+}