summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/vault/vault-0.1.2-r1.ebuild')
-rw-r--r--app-admin/vault/vault-0.1.2-r1.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/app-admin/vault/vault-0.1.2-r1.ebuild b/app-admin/vault/vault-0.1.2-r1.ebuild
index f2adc6d07eb0..c30bcd2fda19 100644
--- a/app-admin/vault/vault-0.1.2-r1.ebuild
+++ b/app-admin/vault/vault-0.1.2-r1.ebuild
@@ -1,27 +1,32 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit fcaps golang-build systemd user
+inherit eutils fcaps golang-build systemd user
+
+GO_PN="github.com/hashicorp/${PN}"
-KEYWORDS="~amd64"
DESCRIPTION="A tool for managing secrets"
HOMEPAGE="https://vaultproject.io/"
-GO_PN="github.com/hashicorp/${PN}"
-LICENSE="MPL-2.0"
+SRC_URI="
+ https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/mitchellh/gox/archive/v0.3.0.tar.gz -> gox-0.3.0.tar.gz
+ https://github.com/mitchellh/iochan/archive/b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz -> iochan-b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz"
+
SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~amd64"
IUSE=""
+
RESTRICT="test"
DEPEND="dev-go/go-oauth2:="
RDEPEND=""
-SRC_URI="https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
-https://github.com/mitchellh/gox/archive/v0.3.0.tar.gz -> gox-0.3.0.tar.gz
-https://github.com/mitchellh/iochan/archive/b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz -> iochan-b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz"
STRIP_MASK="*.a"
+
S="${WORKDIR}/src/${GO_PN}"
FILECAPS=(
@@ -85,8 +90,11 @@ src_install() {
fowners ${PN}:${PN} /var/log/${PN}
dobin bin/${PN}
- find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
- find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type f -delete
+
+ egit_clean "${WORKDIR}"/{pkg,src}
+
+ find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type f -delete || die
+
while read -r -d '' x; do
x=${x#${WORKDIR}/src}
[[ -d ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x} ||