summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch30
-rw-r--r--app-crypt/seahorse/seahorse-3.32.2.ebuild6
2 files changed, 35 insertions, 1 deletions
diff --git a/app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch b/app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch
new file mode 100644
index 000000000000..38c7ca2c15f7
--- /dev/null
+++ b/app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch
@@ -0,0 +1,30 @@
+From d9db29db567012b7c72e85e1be1fbf55fcc9b667 Mon Sep 17 00:00:00 2001
+From: Niels De Graef <nielsdegraef@gmail.com>
+Date: Sat, 11 May 2019 09:02:34 +0200
+Subject: [PATCH] gkr: Use 0 on empty flags
+
+A Flags-type variable without any flag set can be replaced with 0, so
+this is a safe thing to do. It also prevents us from having to deal with
+the accidental API break in libsecret (see
+https://gitlab.gnome.org/GNOME/libsecret/merge_requests/19)
+---
+ gkr/gkr-keyring-add.vala | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/gkr/gkr-keyring-add.vala b/gkr/gkr-keyring-add.vala
+index 4e92a520..f60c9a22 100644
+--- a/gkr/gkr-keyring-add.vala
++++ b/gkr/gkr-keyring-add.vala
+@@ -41,8 +41,7 @@ public class Seahorse.Gkr.KeyringAdd : Gtk.Dialog {
+
+ var cancellable = Dialog.begin_request(this);
+ var service = Backend.instance().service;
+- Secret.Collection.create.begin(service, this.name_entry.text, null,
+- Secret.CollectionCreateFlags.COLLECTION_CREATE_NONE,
++ Secret.Collection.create.begin(service, this.name_entry.text, null, 0,
+ cancellable, (obj, res) => {
+ /* Clear the operation without cancelling it since it is complete */
+ Dialog.complete_request(this, false);
+--
+2.20.1
+
diff --git a/app-crypt/seahorse/seahorse-3.32.2.ebuild b/app-crypt/seahorse/seahorse-3.32.2.ebuild
index a23ee02bd5aa..3d701d04f420 100644
--- a/app-crypt/seahorse/seahorse-3.32.2.ebuild
+++ b/app-crypt/seahorse/seahorse-3.32.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,6 +38,10 @@ DEPEND="${RDEPEND}
app-crypt/libsecret[vala]
"
+PATCHES=(
+ "${FILESDIR}"/${PV}-libsecret-0.20-compat.patch # included upstream for 3.34
+)
+
src_prepare() {
xdg_src_prepare
vala_src_prepare