summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/vzstats')
-rw-r--r--app-misc/vzstats/Manifest3
-rw-r--r--app-misc/vzstats/metadata.xml28
-rw-r--r--app-misc/vzstats/vzstats-0.3.2.ebuild31
-rw-r--r--app-misc/vzstats/vzstats-0.4.ebuild31
-rw-r--r--app-misc/vzstats/vzstats-0.5.1.ebuild31
5 files changed, 124 insertions, 0 deletions
diff --git a/app-misc/vzstats/Manifest b/app-misc/vzstats/Manifest
new file mode 100644
index 000000000000..371b78a6c056
--- /dev/null
+++ b/app-misc/vzstats/Manifest
@@ -0,0 +1,3 @@
+DIST vzstats-0.3.2.tar.bz2 11560 SHA256 df54a0f1d3012bbb41d231af1590653be32079314bce07be2d0ef5ee035cf027 SHA512 43d7a16ff2f051c94faa00e99d6d77d34707026319c34b61e2354fb2916e06af43b73c4476d1ee98c195b43e6e8bc540d0cb09d4345286682c830cea87abff59 WHIRLPOOL c8f459e9ab089d77266c45d45d75c48f002815dfd693f6c25ba7416a668aa35973ff964e4f8c98f3e5f2448e2bfb875240a6f9d11fee67ba343a098cbec99a08
+DIST vzstats-0.4.tar.bz2 12187 SHA256 ae63a1925611827d773a6123a761788d8ea90a8021a3695d7984baafbffedf0d SHA512 6d9885ce7f5dac3d50afc5583da8f84524ba6600c1587b8df75c12c9f09a273e91482cdd52cef41773c76c8b0d1a8b957ac9f0ecb9125a81e8021e332ab237f7 WHIRLPOOL c20b8deea14b2d61983d4e78bec9e0820fe718d6aac79c370fd62aea474dd37291b38d29297d9544c7cd6926d866e66988c9de8acc53ddc449e37570ca087a9d
+DIST vzstats-0.5.1.tar.bz2 17548 SHA256 eddb2f4f617c2937cc6587269453eb768c0d9fbfd9bdc125b82b5540cb287df3 SHA512 ea58ba065fda6f1e1bebcdd273e231d1da46934d0c5217e1acc0a3ecb2ce5738975d3155939c6f74ba407796ae94af4ba405efdb0c808e9bbbbded48285a6663 WHIRLPOOL 8a694ae07d1caf309332b825da6cc3438fd5fbac956c60ccac3b9c2c7afda59c8171fbad4a00afb0a1b7118966e25275c5fc10ae15b399606737cf875f8f2471
diff --git a/app-misc/vzstats/metadata.xml b/app-misc/vzstats/metadata.xml
new file mode 100644
index 000000000000..a9d54a531d50
--- /dev/null
+++ b/app-misc/vzstats/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+ <description>Primary maintainer, assign bugs to him</description>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>kir@openvz.org</email>
+ <name>Kir Kolyshkin</name>
+ </maintainer>
+ </upstream>
+ <longdescription>This is an OpenVZ component to gather OpenVZ usage and hardware statistics,
+ in order to improve the project.
+
+ Statistics gathered and reported include the following:
+ 1 Hardware info.
+ - CPU, disk, memory/swap, PCI devices
+ 2 Software info.
+ - host distribution, versions of OpenVZ components, kernel version
+ 3 Containers info.
+ - number of containers existing/running/using ploop/using vswap
+ - OS templates of containers
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/vzstats/vzstats-0.3.2.ebuild b/app-misc/vzstats/vzstats-0.3.2.ebuild
new file mode 100644
index 000000000000..91a4d62bf650
--- /dev/null
+++ b/app-misc/vzstats/vzstats-0.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="OpenVZ stats collection daemon"
+HOMEPAGE="http://stats.openvz.org"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ virtual/cron
+ sys-process/cronbase
+ net-misc/curl[ssl]
+ app-portage/gentoolkit
+ sys-cluster/vzctl
+ "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install install-cronjob DESTDIR="${D}"
+ dodoc README
+ newbashcomp bash_completion.sh vzstats
+}
diff --git a/app-misc/vzstats/vzstats-0.4.ebuild b/app-misc/vzstats/vzstats-0.4.ebuild
new file mode 100644
index 000000000000..91a4d62bf650
--- /dev/null
+++ b/app-misc/vzstats/vzstats-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="OpenVZ stats collection daemon"
+HOMEPAGE="http://stats.openvz.org"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ virtual/cron
+ sys-process/cronbase
+ net-misc/curl[ssl]
+ app-portage/gentoolkit
+ sys-cluster/vzctl
+ "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install install-cronjob DESTDIR="${D}"
+ dodoc README
+ newbashcomp bash_completion.sh vzstats
+}
diff --git a/app-misc/vzstats/vzstats-0.5.1.ebuild b/app-misc/vzstats/vzstats-0.5.1.ebuild
new file mode 100644
index 000000000000..91a4d62bf650
--- /dev/null
+++ b/app-misc/vzstats/vzstats-0.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="OpenVZ stats collection daemon"
+HOMEPAGE="http://stats.openvz.org"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ virtual/cron
+ sys-process/cronbase
+ net-misc/curl[ssl]
+ app-portage/gentoolkit
+ sys-cluster/vzctl
+ "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install install-cronjob DESTDIR="${D}"
+ dodoc README
+ newbashcomp bash_completion.sh vzstats
+}