summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/obexd/obexd-0.48.ebuild')
-rw-r--r--app-mobilephone/obexd/obexd-0.48.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-mobilephone/obexd/obexd-0.48.ebuild b/app-mobilephone/obexd/obexd-0.48.ebuild
new file mode 100644
index 000000000000..3d88dbb92c53
--- /dev/null
+++ b/app-mobilephone/obexd/obexd-0.48.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="OBEX Server and Client"
+HOMEPAGE="http://www.bluez.org/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="-eds nokia -server usb"
+
+DOCS="AUTHORS ChangeLog README doc/*.txt"
+
+RDEPEND="eds? ( gnome-extra/evolution-data-server )
+ !eds? ( dev-libs/libical )
+ >=net-wireless/bluez-4.100
+ >=dev-libs/openobex-1.4
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1.4
+ server? ( !app-mobilephone/obex-data-server )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/xz-utils"
+
+src_configure() {
+ econf \
+ --disable-debug \
+ $(use_with eds phonebook ebook) \
+ $(use_enable nokia pcsuite) \
+ $(use_enable server) \
+ $(use_enable usb)
+}