summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ocrad/ocrad-0.22.ebuild')
-rw-r--r--app-text/ocrad/ocrad-0.22.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/ocrad/ocrad-0.22.ebuild b/app-text/ocrad/ocrad-0.22.ebuild
new file mode 100644
index 000000000000..f5abc20baf45
--- /dev/null
+++ b/app-text/ocrad/ocrad-0.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit unpacker toolchain-funcs
+
+DESCRIPTION="GNU Ocrad is an OCR (Optical Character Recognition) program"
+HOMEPAGE="http://www.gnu.org/software/ocrad/ocrad.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="$(unpacker_src_uri_depends)"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ # ./configure is not based on autotools
+ ./configure \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ --prefix=/usr
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+ doinfo doc/${PN}.info
+}