summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimcalc')
-rw-r--r--app-vim/vimcalc/Manifest1
-rw-r--r--app-vim/vimcalc/metadata.xml5
-rw-r--r--app-vim/vimcalc/vimcalc-1.3-r2.ebuild39
-rw-r--r--app-vim/vimcalc/vimcalc-1.3.ebuild27
4 files changed, 72 insertions, 0 deletions
diff --git a/app-vim/vimcalc/Manifest b/app-vim/vimcalc/Manifest
new file mode 100644
index 000000000000..51dacbf94375
--- /dev/null
+++ b/app-vim/vimcalc/Manifest
@@ -0,0 +1 @@
+DIST vimcalc-1.3.zip 24993 SHA256 16216a413f54f2e0143306ae535c620204faf255f3259cfd3f55a68e9f1c6b86 SHA512 1b377f284a7b68d200b08bdacee2080a60412e6ba1fd530eb0075dbc84fba30b37cec45e60d916aa80d057809b79f4d816f3a85f903d0e2fc7d06240dcdbb600 WHIRLPOOL b099c23e0c84006a7cb8a1f4d912aa0234a3a063b85de275948882659d75e946ce088f289e2d4b3c750f9b019d8ba15bbff2ef8642487d1ed42b53c95b5e85b7
diff --git a/app-vim/vimcalc/metadata.xml b/app-vim/vimcalc/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/vimcalc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/vimcalc/vimcalc-1.3-r2.ebuild b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
new file mode 100644
index 000000000000..297c20ddb6f9
--- /dev/null
+++ b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: provides an interactive calculator inside vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3329"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=15317 -> ${P}.zip"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="vimcalc"
+
+DEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ # Remove .DS_Store files that should not be installed
+ find -type f -name '.DS*' -delete
+}
+
+src_test() {
+ cd plugin || die
+ "${PYTHON}" tests.py || die "Tests failed"
+}
+
+src_install() {
+ rm plugin/tests.py || die
+ vim-plugin_src_install
+}
diff --git a/app-vim/vimcalc/vimcalc-1.3.ebuild b/app-vim/vimcalc/vimcalc-1.3.ebuild
new file mode 100644
index 000000000000..f16a412c529a
--- /dev/null
+++ b/app-vim/vimcalc/vimcalc-1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: provides an interactive calculator inside vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3329"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=15317 -> ${P}.zip"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimcalc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ =dev-lang/python-2*"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ # Remove .DS_Store files that should not be installed
+ find -type f -name '.*' -exec rm -f {} + || die
+}