summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/files/julia-1.6.5-do_not_set_rpath.patch')
-rw-r--r--dev-lang/julia/files/julia-1.6.5-do_not_set_rpath.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-lang/julia/files/julia-1.6.5-do_not_set_rpath.patch b/dev-lang/julia/files/julia-1.6.5-do_not_set_rpath.patch
new file mode 100644
index 000000000000..c0c05cc649a0
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.6.5-do_not_set_rpath.patch
@@ -0,0 +1,20 @@
+--- a/Makefile 2021-12-21 09:38:26.782829864 +0100
++++ b/Makefile 2021-12-21 10:52:40.760565902 +0100
+@@ -336,7 +336,7 @@
+ install_name_tool -add_rpath @executable_path/$(build_libdir_rel) @executable_path/$(libdir_rel) $(DESTDIR)$(bindir)/$$j; \
+ done
+ endif
+-else ifneq (,$(findstring $(OS),Linux FreeBSD))
++else ifneq (,$(findstring $(OS),FreeBSD))
+ for j in $(JL_TARGETS) ; do \
+ $(PATCHELF) --set-rpath '$$ORIGIN/$(private_libdir_rel):$$ORIGIN/$(libdir_rel)' $(DESTDIR)$(bindir)/$$j; \
+ done
+@@ -357,7 +357,7 @@
+ endif
+
+ # Set rpath for libjulia-internal, which is moving from `../lib` to `../lib/julia`. We only need to do this for Linux/FreeBSD
+-ifneq (,$(findstring $(OS),Linux FreeBSD))
++ifneq (,$(findstring $(OS),FreeBSD))
+ $(PATCHELF) --set-rpath '$$ORIGIN:$$ORIGIN/$(reverse_private_libdir_rel)' $(DESTDIR)$(private_libdir)/libjulia-internal.$(SHLIB_EXT)
+ ifeq ($(BUNDLE_DEBUG_LIBS),1)
+ $(PATCHELF) --set-rpath '$$ORIGIN:$$ORIGIN/$(reverse_private_libdir_rel)' $(DESTDIR)$(private_libdir)/libjulia-internal-debug.$(SHLIB_EXT)