summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.11.0_alpha1.ebuild')
-rw-r--r--dev-lang/python/python-3.11.0_alpha1.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.11.0_alpha1.ebuild b/dev-lang/python/python-3.11.0_alpha1.ebuild
index c69b8cd0966f..65770c78aa4f 100644
--- a/dev-lang/python/python-3.11.0_alpha1.ebuild
+++ b/dev-lang/python/python-3.11.0_alpha1.ebuild
@@ -193,6 +193,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=