summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mlton/metadata.xml2
-rw-r--r--dev-lang/mlton/mlton-20180207.ebuild6
-rw-r--r--dev-lang/mono/metadata.xml2
-rw-r--r--dev-lang/mono/mono-6.12.0.122.ebuild6
-rw-r--r--dev-lang/python/python-2.7.18_p10.ebuild2
-rw-r--r--dev-lang/python/python-2.7.18_p11.ebuild2
-rw-r--r--dev-lang/python/python-3.10.0_beta2.ebuild4
-rw-r--r--dev-lang/python/python-3.10.0_beta3.ebuild4
-rw-r--r--dev-lang/python/python-3.6.13_p5.ebuild4
-rw-r--r--dev-lang/python/python-3.6.14.ebuild4
-rw-r--r--dev-lang/python/python-3.7.10_p6.ebuild4
-rw-r--r--dev-lang/python/python-3.7.11.ebuild4
-rw-r--r--dev-lang/python/python-3.8.10_p2.ebuild4
-rw-r--r--dev-lang/python/python-3.8.11.ebuild4
-rw-r--r--dev-lang/python/python-3.9.5_p2.ebuild4
-rw-r--r--dev-lang/python/python-3.9.6.ebuild4
-rw-r--r--dev-lang/smlnj/metadata.xml2
-rw-r--r--dev-lang/smlnj/smlnj-110.82.ebuild6
18 files changed, 34 insertions, 34 deletions
diff --git a/dev-lang/mlton/metadata.xml b/dev-lang/mlton/metadata.xml
index bcf28489a614..52a980d81fca 100644
--- a/dev-lang/mlton/metadata.xml
+++ b/dev-lang/mlton/metadata.xml
@@ -9,7 +9,7 @@
<flag name="stage3">After bootstrap building mlton with
dev-lang/smlnj, rebuild mlton with the second stage build of
mlton (recommended).</flag>
- <flag name="pax_kernel">Enable if the user plans to run the
+ <flag name="pax-kernel">Enable if the user plans to run the
package under a pax enabled hardened kernel</flag>
</use>
<upstream>
diff --git a/dev-lang/mlton/mlton-20180207.ebuild b/dev-lang/mlton/mlton-20180207.ebuild
index f55bb40d5a14..8ef03ed2eee9 100644
--- a/dev-lang/mlton/mlton-20180207.ebuild
+++ b/dev-lang/mlton/mlton-20180207.ebuild
@@ -14,14 +14,14 @@ HOMEPAGE="http://www.mlton.org"
LICENSE="HPND MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="binary bootstrap-smlnj stage3 doc pax_kernel"
+IUSE="binary bootstrap-smlnj stage3 doc pax-kernel"
DEPEND="dev-libs/gmp:*
bootstrap-smlnj? ( dev-lang/smlnj )
!bootstrap-smlnj? (
!amd64? ( dev-lang/smlnj )
)
- pax_kernel? ( sys-apps/elfix )
+ pax-kernel? ( sys-apps/elfix )
doc? ( virtual/latex-base )"
RDEPEND="dev-libs/gmp:*"
@@ -175,7 +175,7 @@ mlton_src_compile() {
if [[ ${MULTIBUILD_VARIANT} == $(mlton_bootstrap_variant) ]]; then
emake -j1 \
"bootstrap-smlnj" \
- PAXMARK=$(usex pax_kernel "paxmark.sh" "true") \
+ PAXMARK=$(usex pax-kernel "paxmark.sh" "true") \
CFLAGS="${CFLAGS}" \
WITH_GMP_INC_DIR="${EPREFIX}"/usr/include \
WITH_GMP_LIB_DIR="${EPREFIX}"/$(get_libdir)
diff --git a/dev-lang/mono/metadata.xml b/dev-lang/mono/metadata.xml
index bbf56c224647..debfaeb28dae 100644
--- a/dev-lang/mono/metadata.xml
+++ b/dev-lang/mono/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
- <flag name="pax_kernel">Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
+ <flag name="pax-kernel">Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
<flag name="xen">Make mono generate code that is considerably faster on xen VMs but slightly slower on for normal systems.</flag>
</use>
<upstream>
diff --git a/dev-lang/mono/mono-6.12.0.122.ebuild b/dev-lang/mono/mono-6.12.0.122.ebuild
index 981a76e89442..b1486e782657 100644
--- a/dev-lang/mono/mono-6.12.0.122.ebuild
+++ b/dev-lang/mono/mono-6.12.0.122.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://download.mono-project.com/sources/mono/${P}.tar.xz"
LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux"
-IUSE="doc minimal nls pax_kernel xen"
+IUSE="doc minimal nls pax-kernel xen"
# Note: mono works incorrect with older versions of libgdiplus
# Details on dotnet overlay issue: https://github.com/gentoo/dotnet/issues/429
@@ -31,7 +31,7 @@ RDEPEND="
BDEPEND="
sys-devel/bc
virtual/yacc
- pax_kernel? ( sys-apps/elfix )
+ pax-kernel? ( sys-apps/elfix )
"
PATCHES=(
@@ -66,7 +66,7 @@ src_prepare() {
# get killed in the build proces when MPROTECT is enabled, bug #286280
# RANDMMAP kills the build process too, bug #347365
# We use paxmark.sh to get PT/XT logic, bug #532244
- if use pax_kernel ; then
+ if use pax-kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."
# issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
diff --git a/dev-lang/python/python-2.7.18_p10.ebuild b/dev-lang/python/python-2.7.18_p10.ebuild
index 7a8c21f525e7..0a02ad224a97 100644
--- a/dev-lang/python/python-2.7.18_p10.ebuild
+++ b/dev-lang/python/python-2.7.18_p10.ebuild
@@ -225,7 +225,7 @@ src_compile() {
emake
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
diff --git a/dev-lang/python/python-2.7.18_p11.ebuild b/dev-lang/python/python-2.7.18_p11.ebuild
index 17733be6f118..c583ea726d66 100644
--- a/dev-lang/python/python-2.7.18_p11.ebuild
+++ b/dev-lang/python/python-2.7.18_p11.ebuild
@@ -225,7 +225,7 @@ src_compile() {
emake
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
diff --git a/dev-lang/python/python-3.10.0_beta2.ebuild b/dev-lang/python/python-3.10.0_beta2.ebuild
index e20ed1b73034..818aa5957c75 100644
--- a/dev-lang/python/python-3.10.0_beta2.ebuild
+++ b/dev-lang/python/python-3.10.0_beta2.ebuild
@@ -197,7 +197,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -275,7 +275,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.10.0_beta3.ebuild b/dev-lang/python/python-3.10.0_beta3.ebuild
index e20ed1b73034..818aa5957c75 100644
--- a/dev-lang/python/python-3.10.0_beta3.ebuild
+++ b/dev-lang/python/python-3.10.0_beta3.ebuild
@@ -197,7 +197,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -275,7 +275,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.6.13_p5.ebuild b/dev-lang/python/python-3.6.13_p5.ebuild
index e24be42012b1..01b06863a38e 100644
--- a/dev-lang/python/python-3.6.13_p5.ebuild
+++ b/dev-lang/python/python-3.6.13_p5.ebuild
@@ -182,7 +182,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -261,7 +261,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.6.14.ebuild b/dev-lang/python/python-3.6.14.ebuild
index bbce0c2bb3a4..67dda0865bba 100644
--- a/dev-lang/python/python-3.6.14.ebuild
+++ b/dev-lang/python/python-3.6.14.ebuild
@@ -182,7 +182,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -261,7 +261,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.7.10_p6.ebuild b/dev-lang/python/python-3.7.10_p6.ebuild
index 0e99aadfd9c4..fc1984de3bc1 100644
--- a/dev-lang/python/python-3.7.10_p6.ebuild
+++ b/dev-lang/python/python-3.7.10_p6.ebuild
@@ -175,7 +175,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -254,7 +254,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.7.11.ebuild b/dev-lang/python/python-3.7.11.ebuild
index 1cfc503ae0f0..38c80df2cb93 100644
--- a/dev-lang/python/python-3.7.11.ebuild
+++ b/dev-lang/python/python-3.7.11.ebuild
@@ -175,7 +175,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -254,7 +254,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.8.10_p2.ebuild b/dev-lang/python/python-3.8.10_p2.ebuild
index b1c4a316ec34..3e7b9da36c3b 100644
--- a/dev-lang/python/python-3.8.10_p2.ebuild
+++ b/dev-lang/python/python-3.8.10_p2.ebuild
@@ -183,7 +183,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -262,7 +262,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.8.11.ebuild b/dev-lang/python/python-3.8.11.ebuild
index 0a87aec91800..f3ce31d2a657 100644
--- a/dev-lang/python/python-3.8.11.ebuild
+++ b/dev-lang/python/python-3.8.11.ebuild
@@ -183,7 +183,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -262,7 +262,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.9.5_p2.ebuild b/dev-lang/python/python-3.9.5_p2.ebuild
index ba35fe24eebb..687ad6e769ed 100644
--- a/dev-lang/python/python-3.9.5_p2.ebuild
+++ b/dev-lang/python/python-3.9.5_p2.ebuild
@@ -194,7 +194,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -273,7 +273,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/python/python-3.9.6.ebuild b/dev-lang/python/python-3.9.6.ebuild
index 444f9d6d14b5..6cb6bf8002c2 100644
--- a/dev-lang/python/python-3.9.6.ebuild
+++ b/dev-lang/python/python-3.9.6.ebuild
@@ -194,7 +194,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -273,7 +273,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"
diff --git a/dev-lang/smlnj/metadata.xml b/dev-lang/smlnj/metadata.xml
index e7ce88d55f5e..26bf66298295 100644
--- a/dev-lang/smlnj/metadata.xml
+++ b/dev-lang/smlnj/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
- <flag name="pax_kernel">Enable if the user plans to run the
+ <flag name="pax-kernel">Enable if the user plans to run the
package under a pax enabled hardened kernel</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/smlnj/smlnj-110.82.ebuild b/dev-lang/smlnj/smlnj-110.82.ebuild
index 3565c9baaa6d..68c776772b8d 100644
--- a/dev-lang/smlnj/smlnj-110.82.ebuild
+++ b/dev-lang/smlnj/smlnj-110.82.ebuild
@@ -57,8 +57,8 @@ SLOT="0"
#sparc support should be there but is untested
KEYWORDS="-* ~amd64 ~ppc ~x86"
-IUSE="pax_kernel"
-DEPEND="pax_kernel? ( sys-apps/elfix )"
+IUSE="pax-kernel"
+DEPEND="pax-kernel? ( sys-apps/elfix )"
RDEPEND=""
S=${WORKDIR}
@@ -87,7 +87,7 @@ src_prepare() {
-e "/^CC/s:gcc:$(tc-getCC):" \
-e "/^CPP/s:gcc:$(tc-getCC):" \
-e "/^CFLAGS/{s:-O[0123s]:: ; s:=:= ${CFLAGS}:}" \
- -e "/^PAXMARK/s:true:"$(usex pax_kernel "paxmark.sh" "true")":" \
+ -e "/^PAXMARK/s:true:"$(usex pax-kernel "paxmark.sh" "true")":" \
-i base/runtime/objs/${file}
done
}