summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/qoauth')
-rw-r--r--dev-libs/qoauth/Manifest1
-rw-r--r--dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch20
-rw-r--r--dev-libs/qoauth/metadata.xml5
-rw-r--r--dev-libs/qoauth/qoauth-1.0.1.ebuild69
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-libs/qoauth/Manifest b/dev-libs/qoauth/Manifest
new file mode 100644
index 000000000000..bdad95ef7b08
--- /dev/null
+++ b/dev-libs/qoauth/Manifest
@@ -0,0 +1 @@
+DIST qoauth-1.0.1-src.tar.bz2 42298 SHA256 b8579a77cecb07928e557c4a019db902a0f040b22f7926f147299e87ac5a54fd SHA512 86869c82e6efd490888f3bb16cba5bb014821e35507d3d396a84f5112a2d0bd7cb1251ba5dff82a8913eeae77a0feeebfdf4a7d1e9870023fb3c106d603c3dd8 WHIRLPOOL e990ad4fbaa7ce3c45eec6f3a49d9404139432e5941882cc73d85520868bdc592604c8b7058866648d27b2001b310848edd239f8c3f9fc4f0bc66c79fee7f8bd
diff --git a/dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch b/dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch
new file mode 100644
index 000000000000..1fd6fd0fc8c9
--- /dev/null
+++ b/dev-libs/qoauth/files/qoauth-1.0.1-disable-ft.patch
@@ -0,0 +1,20 @@
+diff --git a/qoauth.pro b/qoauth.pro
+index f09b3be..27d7bb3 100644
+--- a/qoauth.pro
++++ b/qoauth.pro
+@@ -5,6 +5,6 @@ SUBDIRS += src tests
+ CONFIG += ordered
+
+ check.target = check
+-check.commands = ( cd tests/ut_interface && ./ut_interface ) && ( cd tests/ft_interface && ./ft_interface )
++check.commands = ( cd tests/ut_interface && ./ut_interface )
+ check.depends = sub-tests
+ QMAKE_EXTRA_TARGETS += check
+diff --git a/tests/tests.pro b/tests/tests.pro
+index d582750..e010bb0 100644
+--- a/tests/tests.pro
++++ b/tests/tests.pro
+@@ -1,2 +1,2 @@
+ TEMPLATE = subdirs
+-SUBDIRS += ut_interface ft_interface
++SUBDIRS += ut_interface
diff --git a/dev-libs/qoauth/metadata.xml b/dev-libs/qoauth/metadata.xml
new file mode 100644
index 000000000000..dc439f7e84f5
--- /dev/null
+++ b/dev-libs/qoauth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+</pkgmetadata>
diff --git a/dev-libs/qoauth/qoauth-1.0.1.ebuild b/dev-libs/qoauth/qoauth-1.0.1.ebuild
new file mode 100644
index 000000000000..a2fc0305f23e
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-1.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt-based library for OAuth support"
+HOMEPAGE="http://wiki.github.com/ayoy/qoauth"
+SRC_URI="http://files.ayoy.net/qoauth/release/${PV}/src/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="debug doc static-libs test"
+
+COMMON_DEPEND="app-crypt/qca:2[debug?,qt4(+)]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-qt/qttest:4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[openssl]
+"
+
+S=${WORKDIR}/${P}-src
+
+DOCS="README CHANGELOG"
+PATCHES=(
+ # disable functional tests that require network connection
+ # and rely on 3rd party external server (bug #341267)
+ "${FILESDIR}/${P}-disable-ft.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
+ fi
+
+ sed -i -e '/^ *docs \\$/d' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
+ src/src.pro || die "sed failed"
+
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
+}
+
+src_compile() {
+ default
+ if use static-libs; then
+ emake -C src static
+ fi
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use static-libs; then
+ dolib.a "${S}"/lib/lib${PN}.a
+ fi
+
+ if use doc; then
+ doxygen "${S}"/Doxyfile || die "failed to generate documentation"
+ dohtml "${S}"/doc/html/*
+ fi
+}