summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild b/dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild
new file mode 100644
index 000000000000..34977fe7f69d
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-9.0.0.9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils git-r3 llvm
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+EGIT_REPO_URI="https://github.com/rpav/c2ffi.git"
+EGIT_BRANCH="llvm-9.0.0"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-devel/clang:9=
+ sys-devel/llvm:9=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-9.0.0.20191017-fix-lib-location.patch )