summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/stdcompat/stdcompat-19.ebuild')
-rw-r--r--dev-ml/stdcompat/stdcompat-19.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/stdcompat/stdcompat-19.ebuild b/dev-ml/stdcompat/stdcompat-19.ebuild
new file mode 100644
index 000000000000..c89f04625894
--- /dev/null
+++ b/dev-ml/stdcompat/stdcompat-19.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Compatibility module for OCaml standard library"
+HOMEPAGE="https://github.com/thierry-martinez/stdcompat"
+SRC_URI="https://github.com/thierry-martinez/stdcompat/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune
+ dev-ml/findlib[ocamlopt]"
+
+src_configure () {
+ econf --libdir="${EPREFIX}"/usr/$(get_libdir)/ocaml
+}