summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ulex/ulex-1.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-ml/ulex/ulex-1.1.ebuild b/dev-ml/ulex/ulex-1.1.ebuild
index 5ae79cbebc2f..a86c973b8daa 100644
--- a/dev-ml/ulex/ulex-1.1.ebuild
+++ b/dev-ml/ulex/ulex-1.1.ebuild
@@ -15,9 +15,10 @@ SLOT="0/${PV}"
KEYWORDS="amd64 ppc x86"
IUSE="+ocamlopt"
-DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
-RDEPEND="${DEPEND}"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ || ( dev-ml/ocamlbuild <dev-lang/ocaml-4.02.3-r1 )"
src_compile() {
emake all