summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Math-BigInt-GMP')
-rw-r--r--dev-perl/Math-BigInt-GMP/Manifest1
-rw-r--r--dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.600.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-GMP/Manifest b/dev-perl/Math-BigInt-GMP/Manifest
index 71dcf823ca15..1aef17a52251 100644
--- a/dev-perl/Math-BigInt-GMP/Manifest
+++ b/dev-perl/Math-BigInt-GMP/Manifest
@@ -1 +1,2 @@
DIST Math-BigInt-GMP-1.6002.tar.gz 2286788 BLAKE2B 2538a0466458162bb7cf2f98c6233a7fa97bf30f3c9a92e82e0c266c9b1c6735dfa8a9310bb2009ff942edf2f10918a28484dd32a76f5ef6cbe7bcdb78de007a SHA512 1c3a4a616bfb386e246ca7fd784954c97fa3a20997db0372e7f4691896e5633e2abb9d9ca42fb781a169d10d36dd3a59759399485a1859cc95c4cf7ff4e5ca09
+DIST Math-BigInt-GMP-1.6006.tar.gz 2460173 BLAKE2B 29d448e01aef4f6b1e91a2a82a284db4f6cf0e92b39a678dbea7fa9458c48813775865f24603a5189b3fd4137378aa9c0b588c2c554372411482fd733339e2be SHA512 9ac48f8b136d835d6a1a90fb4170321f8684f6650e49dcf7ee2147d7ee0f89400ac93aa72deb8b5c5fd56d2ada391789f573f97487e46a3863e6735f2f53828c
diff --git a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.600.ebuild b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.600.ebuild
new file mode 100644
index 000000000000..2942d1ba3833
--- /dev/null
+++ b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.600.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.6006
+inherit perl-module
+
+DESCRIPTION="Use the GMP library for Math::BigInt routines"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.812
+ >=virtual/perl-XSLoader-0.20.0
+ >=dev-libs/gmp-4.0.0:0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.580.0
+ test? ( >=virtual/perl-Test-Simple-0.820.0 )
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/00sig.t t/02pod.t t/03podcov.t
+ perl-module_src_test
+}