summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Number-WithError/Number-WithError-1.10.0-r1.ebuild')
-rw-r--r--dev-perl/Number-WithError/Number-WithError-1.10.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Number-WithError/Number-WithError-1.10.0-r1.ebuild b/dev-perl/Number-WithError/Number-WithError-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..cec229a6f192
--- /dev/null
+++ b/dev-perl/Number-WithError/Number-WithError-1.10.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SMUELLER
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Numbers with error propagation and scientific rounding"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.400.0
+ >=dev-perl/Params-Util-0.100.0
+ >=dev-perl/prefork-1.0.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ dev-perl/Test-LectroTest
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
+)
+
+PERL_RM_FILES=(
+ "t/00podcover.t"
+ "t/00pod.t"
+)