summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Time-Format/Time-Format-1.160.0.ebuild')
-rw-r--r--dev-perl/Time-Format/Time-Format-1.160.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Time-Format/Time-Format-1.160.0.ebuild b/dev-perl/Time-Format/Time-Format-1.160.0.ebuild
new file mode 100644
index 000000000000..542a6e09cff5
--- /dev/null
+++ b/dev-perl/Time-Format/Time-Format-1.160.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ROODE
+DIST_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="Easy-to-use date/time formatting"
+LICENSE="Time-Format"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Date-Manip
+ >=virtual/perl-Time-Local-1.70.0
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ test? ( >=virtual/perl-Test-Simple-0.400.0 )
+"
+
+PERL_RM_FILES=( "t/0-signature.t" "SIGNATURE" )
+
+src_configure() {
+ export TZ=UTC # https://rt.cpan.org/Public/Bug/Display.html?id=85001
+ perl-module_src_configure
+}