summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jinja/jinja-2.10.3-r1.ebuild')
-rw-r--r--dev-python/jinja/jinja-2.10.3-r1.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/jinja/jinja-2.10.3-r1.ebuild b/dev-python/jinja/jinja-2.10.3-r1.ebuild
deleted file mode 100644
index c5fe4cba443e..000000000000
--- a/dev-python/jinja/jinja-2.10.3-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
-# pypi tarball is missing tests
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/markupsafe[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-issues \
- dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-# XXX: handle Babel better?
-
-wrap_opts() {
- local mydistutilsargs=()
-
- if [[ ${EPYTHON} == python* ]]; then
- mydistutilargs+=( --with-debugsupport )
- fi
-
- "${@}"
-}
-
-src_prepare() {
- # avoid unnecessary dep on extra sphinxcontrib modules
- sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
- printf "############################# SED ###############################\n"
-
- distutils-r1_src_prepare
-}
-
-python_prepare() {
- # async is not supported on python2
- if ! python_is_python3; then
- rm -f jinja2/async*.py || die "Failed to remove async from python2"
- fi
-}
-
-python_compile() {
- wrap_opts distutils-r1_python_compile
-}
-
-python_install_all() {
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/*
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}