summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pendulum/pendulum-2.1.2-r2.ebuild')
-rw-r--r--dev-python/pendulum/pendulum-2.1.2-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pendulum/pendulum-2.1.2-r2.ebuild b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
new file mode 100644
index 000000000000..8ed0456d4293
--- /dev/null
+++ b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for the standard datetime class"
+HOMEPAGE="
+ https://pendulum.eustace.io/
+ https://github.com/sdispater/pendulum/
+ https://pypi.org/project/pendulum/
+"
+SRC_URI="
+ https://github.com/sdispater/pendulum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+DEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytzdata[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest