summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint-venv/pylint-venv-3.0.0.ebuild')
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
index ad1160f14a79..f90bdef4e3a8 100644
--- a/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
+++ b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
@@ -39,5 +39,8 @@ src_prepare() {
}
python_test() {
+ # we need to set PYTHONPATH explicitly since the test runs installed
+ # pylint (i.e. starts outside the test venv)
+ local -x PYTHONPATH=${S}:${PYTHONPATH}
bash test/test.sh || die "Test failed with ${EPYTHON}"
}