summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
index d85bc8bcd009..9bb95d7201ad 100644
--- a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
@@ -17,7 +17,15 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 s
BDEPEND="
>=dev-python/pytest-5.0[${PYTHON_USEDEP}]
- test? ( !!dev-python/flaky )
"
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=,xdist.plugin
+ fi
+ epytest
+}