summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.2.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index ddc7cd033cda..eb46b5b19ba3 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,3 +1,4 @@
DIST django-otp-1.1.6.gh.tar.gz 76790 BLAKE2B 442c2418a870ccc8034a080415befb09780f9228562a15737e0911a0343945908f9fc2e026220a4477a5e5e1a6c1e4c3f7d51c823d4a9019f2bc15ae3367d8a3 SHA512 58c64651a5b274542bf09604daf3e59fdb0ea4eb96e7d14e59fd10a042d86cffb5df462191198f12320ea706f4d9aa651ef2c79ad7aa33e9d4ba0d157d90f4fb
DIST django_otp-1.2.0.tar.gz 64888 BLAKE2B 4b9eff29508b1ce537452ecf7337c7440acbab08b66c651080973d6a39e8e7cd5255f440e4dfb397886f562234d297333eee296ee9958075790e183e47e6637a SHA512 2f108ff08a01044a0f6572f4e5a57311c28926b5baf808f5013e6ffc1e40db77fd182b078ce53596b4ecee87fc0223fdf6fc41158e03a6ba3e80455234d64810
DIST django_otp-1.2.1.tar.gz 65762 BLAKE2B 8243763a717c5f22513e10a03b8eeccf26d5e556cca15a22cad8e66ae8f6b4e6bfd53c43bf4de328e0b78f66895869a258ed1f42daaa0c3f686ae42ae0222ee5 SHA512 cb1ee0507dca15cd23d96c28566368079d38d85e3ef3a11ac14d25443c7d50ee62e8256dafe355632c33c84f74af54146890e58e17dc588e52502ee68716510f
+DIST django_otp-1.2.2.tar.gz 66391 BLAKE2B f66472ec2e3842ebc634edd8f689d1de51738381fd86c4af0859dee2f1bcf407b1c952c795203f9c742a95633ee14ce9253dcc1ffd7988c960e26b23a1ec5dfe SHA512 e8608f0a3b0aeaa82e509f034f69131eb1015124ecf84b734a5be58f62c309eee506b12fffe2aeb4b707e70c612413d1458bc64533102508c55255035432eb1f
diff --git a/dev-python/django-otp/django-otp-1.2.2.ebuild b/dev-python/django-otp/django-otp-1.2.2.ebuild
new file mode 100644
index 000000000000..fae3a5117ea5
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}