summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qt-creator/qt-creator-15.0.1.ebuild2
-rw-r--r--dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133500.patch58
-rw-r--r--dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133808.patch12
-rw-r--r--dev-qt/qtbase/qtbase-6.8.2-r2.ebuild (renamed from dev-qt/qtbase/qtbase-6.8.2.ebuild)2
-rw-r--r--dev-qt/qtstyleplugins/Manifest1
-rw-r--r--dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch47
-rw-r--r--dev-qt/qtstyleplugins/metadata.xml11
-rw-r--r--dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311-r1.ebuild46
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-6.8.2-glibc2.41.patch22
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.8.2-r1.ebuild (renamed from dev-qt/qtwebengine/qtwebengine-6.8.2.ebuild)1
10 files changed, 96 insertions, 106 deletions
diff --git a/dev-qt/qt-creator/qt-creator-15.0.1.ebuild b/dev-qt/qt-creator/qt-creator-15.0.1.ebuild
index 3ed1685d4f1f..13cd21f43e32 100644
--- a/dev-qt/qt-creator/qt-creator-15.0.1.ebuild
+++ b/dev-qt/qt-creator/qt-creator-15.0.1.ebuild
@@ -29,7 +29,7 @@ else
cmdbridge-server? ( https://dev.gentoo.org/~ionen/distfiles/${QTC_P}-vendor.tar.xz )
"
S=${WORKDIR}/${QTC_P}
- KEYWORDS="~amd64"
+ KEYWORDS="amd64"
fi
DESCRIPTION="Lightweight IDE for C++/QML development centering around Qt"
diff --git a/dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133500.patch b/dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133500.patch
new file mode 100644
index 000000000000..89a388eed6aa
--- /dev/null
+++ b/dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133500.patch
@@ -0,0 +1,58 @@
+Combined backport of [1][2][3] from upcoming Qt 6.8.3 for [4][5][6].
+
+[1] https://github.com/qt/qtbase/commit/12d4bf1ab52748cb84894f50d437064b439e0b7d
+[2] https://github.com/qt/qtbase/commit/2ef615228bba9a8eb282437bfb7472f925610e89
+[3] https://github.com/qt/qtbase/commit/a43c7e58046604796aa69974ea1c5d3e2648c755
+[4] https://bugreports.qt.io/browse/QTBUG-133206
+[5] https://bugreports.qt.io/browse/QTBUG-133500
+[6] https://bugs.kde.org/show_bug.cgi?id=499537
+--- a/src/corelib/global/qlibraryinfo.cpp
++++ b/src/corelib/global/qlibraryinfo.cpp
+@@ -7,4 +7,5 @@
+ #include "qfile.h"
+ #if QT_CONFIG(settings)
++#include "qresource.h"
+ #include "qsettings.h"
+ #endif
+@@ -104,5 +105,5 @@
+
+ QString qtconfig = QStringLiteral(":/qt/etc/qt.conf");
+- if (QFile::exists(qtconfig))
++ if (QResource(qtconfig, QLocale::c()).isValid())
+ return std::make_unique<QSettings>(qtconfig, QSettings::IniFormat);
+ #ifdef Q_OS_DARWIN
+--- a/src/corelib/text/qlocale.cpp
++++ b/src/corelib/text/qlocale.cpp
+@@ -1113,8 +1113,11 @@
+
+ QLocale::QLocale()
+- : d(*defaultLocalePrivate)
++ : d(c_private())
+ {
+- // Make sure system data is up to date:
+- systemData();
++ if (!defaultLocalePrivate.isDestroyed()) {
++ // Make sure system data is up to date:
++ systemData();
++ d = *defaultLocalePrivate;
++ }
+ }
+
+--- a/src/corelib/text/qlocale_unix.cpp
++++ b/src/corelib/text/qlocale_unix.cpp
+@@ -128,4 +128,6 @@
+ {
+ QSystemLocaleData *d = qSystemLocaleData();
++ if (!d)
++ return QVariant();
+
+ if (type == LocaleChanged) {
+--- a/src/corelib/text/qlocale_win.cpp
++++ b/src/corelib/text/qlocale_win.cpp
+@@ -829,4 +829,6 @@
+ {
+ QSystemLocalePrivate *d = systemLocalePrivate();
++ if (!d)
++ return QVariant();
+ switch(type) {
+ case DecimalPoint:
diff --git a/dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133808.patch b/dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133808.patch
new file mode 100644
index 000000000000..f15eb4167686
--- /dev/null
+++ b/dev-qt/qtbase/files/qtbase-6.8.2-QTBUG-133808.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/949629
+https://bugreports.qt.io/browse/QTBUG-133808
+https://codereview.qt-project.org/c/qt/qtbase/+/624870
+--- a/src/corelib/global/qcompare_impl.h
++++ b/src/corelib/global/qcompare_impl.h
+@@ -13,4 +13,6 @@
+ #include <QtCore/qcompilerdetection.h>
+
++#include <type_traits>
++
+ QT_BEGIN_NAMESPACE
+
diff --git a/dev-qt/qtbase/qtbase-6.8.2.ebuild b/dev-qt/qtbase/qtbase-6.8.2-r2.ebuild
index a4a17c32f1ed..2a5d8cbc90ac 100644
--- a/dev-qt/qtbase/qtbase-6.8.2.ebuild
+++ b/dev-qt/qtbase/qtbase-6.8.2-r2.ebuild
@@ -146,6 +146,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.6.1-forkfd-childstack-size.patch
"${FILESDIR}"/${PN}-6.6.3-gcc14-avx512fp16.patch
"${FILESDIR}"/${PN}-6.8.0-qcontiguouscache.patch
+ "${FILESDIR}"/${P}-QTBUG-133500.patch
+ "${FILESDIR}"/${P}-QTBUG-133808.patch
)
src_prepare() {
diff --git a/dev-qt/qtstyleplugins/Manifest b/dev-qt/qtstyleplugins/Manifest
deleted file mode 100644
index 2e8f46bed53d..000000000000
--- a/dev-qt/qtstyleplugins/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST qtstyleplugins-5.0.0_p20170311.tar.gz 306394 BLAKE2B a59343602062ec1d0f215acf568322a5be874552b0c03dec75f268cec2123b1baa30bee524e36c9d522a8c935a58f204b5362feaf028df87ca10ea01dd29b3fb SHA512 e8c2d0e9c6b0a47cab04ffd2e9384606638905b63a7c1580f9b629bbcc84ebff19743363ffee3dbd31c3de1dcda684211ad3052932b5aa0081e529afd9cbb14d
diff --git a/dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch b/dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch
deleted file mode 100644
index caedd05baa83..000000000000
--- a/dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From: Fabian Vogt <fvogt@suse.de>
-Subject: Fix build against Qt 5.15
-
-With 0a93db4d82c051164923a10e4382b12de9049b45
-("Unify application palette handling between QGuiApplication and QApplication")
-QApplicationPrivate::setSystemPalette does no longer exist.
-
-This style does explictly not support "system colors" defined by the platform
-theme, which have priority over the style provided palette. To prevent the
-theme from overriding the colors, it previously used the system palette
-mechanism (which has priority over the theme), but that way does not work
-anymore. Instead, simply use QApplication::setPalette. While that has
-different behaviour and might break in some applications, it's better than
-having a completely messed up palette with certain themes.
-This is the same change as suggested by gamezelda on
-https://aur.archlinux.org/packages/qt5-styleplugins/#comment-749190.
-
-Index: qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle.cpp
-===================================================================
---- qtstyleplugins-opensource-src-5.0.0+git20170311.orig/src/plugins/styles/gtk2/qgtkstyle.cpp
-+++ qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle.cpp
-@@ -440,7 +440,11 @@ void QGtkStyle::polish(QApplication *app
- // not supported as these should be entirely determined by
- // current Gtk settings
- if (app->desktopSettingsAware() && d->isThemeAvailable()) {
-+#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
- QApplicationPrivate::setSystemPalette(standardPalette());
-+#else
-+ QApplication::setPalette(standardPalette());
-+#endif
- QApplicationPrivate::setSystemFont(d->getThemeFont());
- d->applyCustomPaletteHash();
- if (!d->isKDE4Session())
-Index: qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle_p.cpp
-===================================================================
---- qtstyleplugins-opensource-src-5.0.0+git20170311.orig/src/plugins/styles/gtk2/qgtkstyle_p.cpp
-+++ qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle_p.cpp
-@@ -508,7 +508,9 @@ void QGtkStyleUpdateScheduler::updateThe
- if (oldTheme != QGtkStylePrivate::getThemeName()) {
- oldTheme = QGtkStylePrivate::getThemeName();
- QPalette newPalette = qApp->style()->standardPalette();
-+#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
- QApplicationPrivate::setSystemPalette(newPalette);
-+#endif
- QApplication::setPalette(newPalette);
- if (!QGtkStylePrivate::instances.isEmpty()) {
- QGtkStylePrivate::instances.last()->initGtkWidgets();
diff --git a/dev-qt/qtstyleplugins/metadata.xml b/dev-qt/qtstyleplugins/metadata.xml
deleted file mode 100644
index 6498a5bbb7e6..000000000000
--- a/dev-qt/qtstyleplugins/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>chewi@gentoo.org</email>
- <name>James Le Cuirot</name>
- </maintainer>
- <upstream>
- <remote-id type="github">qt/qtstyleplugins</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311-r1.ebuild b/dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311-r1.ebuild
deleted file mode 100644
index e22f656abe1d..000000000000
--- a/dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils
-
-COMMIT="335dbece103e2cbf6c7cf819ab6672c2956b17b3"
-DESCRIPTION="Additional style plugins for Qt5 (gtk2, cleanlook, plastic, motif)"
-HOMEPAGE="https://code.qt.io/cgit/qt/qtstyleplugins.git/"
-SRC_URI="https://github.com/qt/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="5"
-KEYWORDS="amd64"
-
-DEPEND="
- dev-qt/qtcore:5=
- dev-qt/qtgui:5=[dbus]
- dev-qt/qtwidgets:5=
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/pango
-"
-
-RDEPEND="
- ${DEPEND}
-"
-
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-PATCHES=(
- "${FILESDIR}"/fix-build-qt5.15.patch
-)
-
-src_configure() {
- eqmake5
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
-}
-
-pkg_postinst() {
- elog "To make Qt5 use the gtk2 style, set this in your environment:"
- elog " QT_QPA_PLATFORMTHEME=gtk2"
-}
diff --git a/dev-qt/qtwebengine/files/qtwebengine-6.8.2-glibc2.41.patch b/dev-qt/qtwebengine/files/qtwebengine-6.8.2-glibc2.41.patch
new file mode 100644
index 000000000000..eaaf7cbc57f0
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-6.8.2-glibc2.41.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/949654
+
+Quick downstream fix for now. Hasn't been sent to upstream(s) yet
+as of the writing of this, but believe it should happen soon.
+--- a/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions.cc
++++ b/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions.cc
+@@ -36,4 +36,8 @@
+ #include "sandbox/linux/system_headers/linux_time.h"
+
++#if !defined(MAP_DROPPABLE)
++#define MAP_DROPPABLE 0x08 // Zero memory under memory pressure.
++#endif
++
+ #if (BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_CHROMEOS_LACROS)) && \
+ !defined(__arm__) && !defined(__aarch64__) && \
+@@ -239,5 +243,5 @@
+ const uint64_t kAllowedMask = MAP_SHARED | MAP_PRIVATE | MAP_ANONYMOUS |
+ MAP_STACK | MAP_NORESERVE | MAP_FIXED |
+- MAP_DENYWRITE | MAP_LOCKED |
++ MAP_DENYWRITE | MAP_LOCKED | MAP_DROPPABLE |
+ kArchSpecificAllowedMask;
+ const Arg<int> flags(3);
diff --git a/dev-qt/qtwebengine/qtwebengine-6.8.2.ebuild b/dev-qt/qtwebengine/qtwebengine-6.8.2-r1.ebuild
index 0988f8bb29d5..5953fdc5e01c 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.8.2.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.8.2-r1.ebuild
@@ -110,6 +110,7 @@ PATCHES+=(
# add extras as needed here, may merge in set if carries across versions
"${FILESDIR}"/${PN}-6.8.1-aarch64-xnnpack.patch
"${FILESDIR}"/${PN}-6.8.1-cstdint.patch
+ "${FILESDIR}"/${PN}-6.8.2-glibc2.41.patch
)
python_check_deps() {