summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-support/rspec-support-3.3.0.ebuild')
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.3.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/rspec-support/rspec-support-3.3.0.ebuild b/dev-ruby/rspec-support/rspec-support-3.3.0.ebuild
deleted file mode 100644
index d6fd484b91e2..000000000000
--- a/dev-ruby/rspec-support/rspec-support-3.3.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="https://github.com/rspec/rspec-support"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-3.3.0:3 )"
-
-all_ruby_prepare() {
- sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Remove spec that, by following symlinks, tries to scan pretty much
- # the whole filesystem.
- rm spec/rspec/support/caller_filter_spec.rb || die
-}