summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/owl-lisp/owl-lisp-9999.ebuild')
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-9999.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/dev-scheme/owl-lisp/owl-lisp-9999.ebuild b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
index 551dda855179..b1789ff9873e 100644
--- a/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
+++ b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
-
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Purely functional dialect of Scheme"
-HOMEPAGE="https://haltp.org/posts/owl.html"
+HOMEPAGE="https://haltp.org/posts/owl.html
+ https://gitlab.com/owl-lisp/owl/"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
else
- SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v${PV}/owl-v${PV}.tar.gz"
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v${PV}/owl-v${PV}.tar.bz2"
KEYWORDS="~amd64"
S="${WORKDIR}/owl-v${PV}"
fi
@@ -22,15 +21,25 @@ fi
LICENSE="MIT"
SLOT="0"
+PATCHES=( "${FILESDIR}"/${PN}-0.2.1-make-no-test.patch )
+
+src_prepare() {
+ default
+
+ # Skip "tests/char-ready.sh", "does not work in background subshell".
+ rm tests/char-ready.sh || die
+}
+
src_compile(){
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" owl
}
src_install() {
- einstalldocs
+ exeinto /usr/bin
+ doexe "${S}"/bin/ol
+ newexe "${S}"/bin/vm ovm
- dobin ./bin/ol
- newbin ./bin/vm ovm
+ doman "${S}"/doc/*.1
- doman ./doc/*.1
+ einstalldocs
}