summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pulseaudio/pulseaudio-12.0-r1.ebuild')
-rw-r--r--media-sound/pulseaudio/pulseaudio-12.0-r1.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/media-sound/pulseaudio/pulseaudio-12.0-r1.ebuild b/media-sound/pulseaudio/pulseaudio-12.0-r1.ebuild
index 7244e687d132..4b4924da9440 100644
--- a/media-sound/pulseaudio/pulseaudio-12.0-r1.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-12.0-r1.ebuild
@@ -277,6 +277,12 @@ multilib_src_install_all() {
doinitd "${T}/pulseaudio"
systemd_dounit "${FILESDIR}/${PN}.service"
+
+ # We need /var/run/pulse, bug #442852
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+ else
+ # Prevent warnings when system-wide is not used, bug #447694
+ rm "${ED%/}"/etc/dbus-1/system.d/pulseaudio-system.conf || die
fi
if use zeroconf ; then
@@ -289,14 +295,6 @@ multilib_src_install_all() {
# Create the state directory
use prefix || diropts -o pulse -g pulse -m0755
- # We need /var/run/pulse, bug #442852
- use system-wide && systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
-
- # Prevent warnings when system-wide is not used, bug #447694
- if ! use system-wide ; then
- rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf || die
- fi
-
find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
}