summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-check_openvpn-simple')
-rw-r--r--net-analyzer/nagios-check_openvpn-simple/Manifest1
-rw-r--r--net-analyzer/nagios-check_openvpn-simple/metadata.xml8
-rw-r--r--net-analyzer/nagios-check_openvpn-simple/nagios-check_openvpn-simple-0.0.1.ebuild40
3 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_openvpn-simple/Manifest b/net-analyzer/nagios-check_openvpn-simple/Manifest
new file mode 100644
index 000000000000..7766d1544be2
--- /dev/null
+++ b/net-analyzer/nagios-check_openvpn-simple/Manifest
@@ -0,0 +1 @@
+DIST check_openvpn-simple-0.0.1.tar.gz 13597 SHA256 f761c7e5c4673b62ef50bb67be61efe178791fc5aa54c62695c5fee7f4a50fae SHA512 186575e4de4fd5f27f9701b5e5a56d8b6eae454bfefd8b13e6cbcee9da795833a567fc7a4fc5331a1498f6c0428599f0ec895acecb410e95e37ed43df58abc8f WHIRLPOOL 8441b69f83526bbda730d61a26fe3ce62bb70963ce5220c77c60e19c5772adb3508ba73f768b02e5640b8e8e1e42c5a1c70b6bdbb14d18417c406bb5d885deba
diff --git a/net-analyzer/nagios-check_openvpn-simple/metadata.xml b/net-analyzer/nagios-check_openvpn-simple/metadata.xml
new file mode 100644
index 000000000000..df7fdbeaf2b3
--- /dev/null
+++ b/net-analyzer/nagios-check_openvpn-simple/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-check_openvpn-simple/nagios-check_openvpn-simple-0.0.1.ebuild b/net-analyzer/nagios-check_openvpn-simple/nagios-check_openvpn-simple-0.0.1.ebuild
new file mode 100644
index 000000000000..d80db5607f06
--- /dev/null
+++ b/net-analyzer/nagios-check_openvpn-simple/nagios-check_openvpn-simple-0.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1 multilib
+
+MY_PN="${PN/nagios-/}"
+MY_P="${P/nagios-/}"
+DESCRIPTION="A Nagios plugin to check whether an OpenVPN server is alive"
+HOMEPAGE="http://michael.orlitzky.com/code/${MY_PN}.php"
+SRC_URI="http://michael.orlitzky.com/code/releases/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}