summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-20.18.0.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-20.18.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-libs/nodejs/nodejs-20.18.0.ebuild b/net-libs/nodejs/nodejs-20.18.0.ebuild
index 1a9f823fb862..a06c32bdae99 100644
--- a/net-libs/nodejs/nodejs-20.18.0.ebuild
+++ b/net-libs/nodejs/nodejs-20.18.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CONFIG_CHECK="~ADVISE_SYSCALLS"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -113,7 +113,7 @@ src_configure() {
filter-lto
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"