summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/ripole/ripole-0.2.1.ebuild')
-rw-r--r--net-mail/ripole/ripole-0.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mail/ripole/ripole-0.2.1.ebuild b/net-mail/ripole/ripole-0.2.1.ebuild
new file mode 100644
index 000000000000..43744da95c2d
--- /dev/null
+++ b/net-mail/ripole/ripole-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program/library to pull out attachment from OLE2 data files"
+HOMEPAGE="http://www.pldaniels.com/ripole/"
+SRC_URI="http://www.pldaniels.com/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 hppa ~sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.0-ldflags.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ripole
+ dodoc CHANGELOG README CONTRIBUTORS
+}