summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sslh/sslh-1.18-r1.ebuild')
-rw-r--r--net-misc/sslh/sslh-1.18-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-misc/sslh/sslh-1.18-r1.ebuild b/net-misc/sslh/sslh-1.18-r1.ebuild
index 15c62e02d404..cfff780590b9 100644
--- a/net-misc/sslh/sslh-1.18-r1.ebuild
+++ b/net-misc/sslh/sslh-1.18-r1.ebuild
@@ -5,7 +5,7 @@
EAPI=6
MY_P="${PN}-v${PV}"
-inherit systemd toolchain-funcs
+inherit flag-o-matic systemd toolchain-funcs
DESCRIPTION="Port multiplexer - accept both HTTPS and SSH connections on the same port"
HOMEPAGE="http://www.rutschle.net/tech/sslh.shtml"
@@ -33,6 +33,13 @@ PATCHES=(
)
src_compile() {
+ # On older versions of GCC, the default gnu89 variant
+ # will reject within-for-loop initializers, bug #595426
+ # Furthermore, we need to use the gnu variant (gnu99) instead
+ # of the ISO (c99) variant, as we want the __USE_XOPEN2K macro
+ # to be defined.
+ append-cflags -std=gnu99
+
emake \
CC="$(tc-getCC)" \
USELIBCAP=$(usev caps) \