summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild')
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild b/sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild
index c5b11ff74339..4f1c7f328431 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -87,6 +87,16 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
# test? ( dev-java/junit:4 )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.98.490-prefs.patch"
+ "${FILESDIR}/${PN}-0.99.473-paths.patch"
+ "${FILESDIR}/${PN}-0.99.473-clang-pandoc.patch"
+ "${FILESDIR}/${PN}-0.98.490-linker_flags.patch"
+ "${FILESDIR}/${PN}-0.98.1091-boost-1.57.patch"
+ "${FILESDIR}/${PN}-0.99.473-qtsingleapplication.patch"
+ "${FILESDIR}/${PN}-0.99.486-systemd.patch"
+)
+
src_unpack() {
unpack ${P}.tar.gz gwt-${GWT_VER}.zip
cd "${S}" || die
@@ -125,13 +135,7 @@ src_prepare() {
find . -name .gitignore -delete || die
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
- "${FILESDIR}"/${PN}-0.99.473-paths.patch \
- "${FILESDIR}"/${PN}-0.99.473-clang-pandoc.patch \
- "${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \
- "${FILESDIR}"/${PN}-0.98.1091-boost-1.57.patch \
- "${FILESDIR}"/${PN}-0.99.473-qtsingleapplication.patch \
- "${FILESDIR}"/${PN}-0.99.486-systemd.patch
+ epatch "${PATCHES[@]}"
# Enable CMake to install our .service file for systemd usage
mkdir -vp "${S}/src/cpp/server/lib/systemd/system" || die