summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/firefox-48.0-pgo.patch12
-rw-r--r--www-client/firefox/firefox-48.0.ebuild5
2 files changed, 15 insertions, 2 deletions
diff --git a/www-client/firefox/files/firefox-48.0-pgo.patch b/www-client/firefox/files/firefox-48.0-pgo.patch
new file mode 100644
index 000000000000..645c0085e227
--- /dev/null
+++ b/www-client/firefox/files/firefox-48.0-pgo.patch
@@ -0,0 +1,12 @@
+--- firefox-47.0.1/Makefile.in.orig 2016-06-01 07:11:37.000000000 +0300
++++ firefox-47.0.1/Makefile.in 2016-08-06 16:45:14.442699244 +0300
+@@ -55,6 +55,9 @@
+ endif
+ endif
+
++pgo-profile-run:
++ $(PYTHON) $(topsrcdir)/build/pgo/profileserver.py $(EXTRA_TEST_ARGS)
++
+ ifdef JS_STANDALONE
+ .PHONY: CLOBBER
+ CLOBBER:
diff --git a/www-client/firefox/firefox-48.0.ebuild b/www-client/firefox/firefox-48.0.ebuild
index 33c3f4690517..c430b690c712 100644
--- a/www-client/firefox/firefox-48.0.ebuild
+++ b/www-client/firefox/firefox-48.0.ebuild
@@ -115,7 +115,8 @@ src_unpack() {
src_prepare() {
# Apply our patches
- eapply "${WORKDIR}/firefox"
+ eapply "${WORKDIR}/firefox" \
+ "${FILESDIR}"/${PN}-48.0-pgo.patch
# "${FILESDIR}"/${PN}-45-qt-widget-fix.patch
if ! tc-ld-is-gold && has_version ">=sys-devel/binutils-2.26" ; then
@@ -203,7 +204,7 @@ src_configure() {
# Allow for a proper pgo build
if use pgo; then
- echo "mk_add_options PROFILE_GEN_SCRIPT='\$(PYTHON) \$(OBJDIR)/_profile/pgo/profileserver.py'" >> "${S}"/.mozconfig
+ echo "mk_add_options PROFILE_GEN_SCRIPT='EXTRA_TEST_ARGS=10 \$(MAKE) -C \$(MOZ_OBJDIR) pgo-profile-run'" >> "${S}"/.mozconfig
fi
echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig