summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-06-30 00:45:30 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-06-30 00:50:19 -0700
commit81855e2de38d1069fa9780e19bcf92d3271faf5b (patch)
tree6698997a2343c17cb03f7930b3572861da2e3a84
parentdev-lang/terra: Remove package (diff)
downloadjohnmh-81855e2de38d1069fa9780e19bcf92d3271faf5b.tar.gz
johnmh-81855e2de38d1069fa9780e19bcf92d3271faf5b.tar.bz2
johnmh-81855e2de38d1069fa9780e19bcf92d3271faf5b.zip
gui-apps/wl-clip-persist: Add ebuild
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
-rw-r--r--gui-apps/wl-clip-persist/Manifest1
-rw-r--r--gui-apps/wl-clip-persist/wl-clip-persist-9999.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gui-apps/wl-clip-persist/Manifest b/gui-apps/wl-clip-persist/Manifest
new file mode 100644
index 0000000..2f1e8ab
--- /dev/null
+++ b/gui-apps/wl-clip-persist/Manifest
@@ -0,0 +1 @@
+EBUILD wl-clip-persist-9999.ebuild 619 BLAKE2B 00badc843f12905705e3e84ba6c999e4a2823ccb3c0afe47c7c1f06cca033243dee40edad3c11fca44ae54f78e0cf9d274a09a113ed9b7ff5b92f0c19397e41b SHA512 7163274ccacda9979d956f3a4126e8f0768d19c04cfdacd6c780b9b23163bc29a6bff1985c2943e3d7ae0f726d310a77157fb9f0cb05851bedd8fa64f7e7578f
diff --git a/gui-apps/wl-clip-persist/wl-clip-persist-9999.ebuild b/gui-apps/wl-clip-persist/wl-clip-persist-9999.ebuild
new file mode 100644
index 0000000..039f9d9
--- /dev/null
+++ b/gui-apps/wl-clip-persist/wl-clip-persist-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2024 John M. Harris, Jr.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo git-r3
+
+DESCRIPTION="Keep Wayland clipboard even after programs close"
+HOMEPAGE="https://github.com/Linus789/wl-clip-persist"
+
+EGIT_REPO_URI="https://github.com/Linus789/wl-clip-persist.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-vcs/git"
+RDEPEND="
+ ${DEPEND}
+ gui-libs/wlroots
+"
+
+src_unpack() {
+ git-r3_src_unpack
+ cargo_live_src_unpack
+}
+
+src_configure() {
+ cargo_gen_config
+ cargo_src_configure
+}
+
+src_compile() {
+ cargo_src_compile
+}
+
+src_install() {
+ cargo_src_install
+}