summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Heath <dawan@melix.net>2013-08-16 01:21:56 +0200
committerQuentin Heath <dawan@melix.net>2013-08-16 01:21:56 +0200
commit7085151eeb24247d20095191985b6b4ce30ae512 (patch)
tree687643b41f051d143e5fb29a96bd3a052fe51432 /dev-tex
downloaddawan-7085151eeb24247d20095191985b6b4ce30ae512.tar.gz
dawan-7085151eeb24247d20095191985b6b4ce30ae512.tar.bz2
dawan-7085151eeb24247d20095191985b6b4ce30ae512.zip
again-birth of the repo (was a wee too messy)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/mathpartir/Manifest3
-rw-r--r--dev-tex/mathpartir/mathpartir-1.2.0-r1.ebuild59
-rw-r--r--dev-tex/mathpartir/metadata.xml26
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-tex/mathpartir/Manifest b/dev-tex/mathpartir/Manifest
new file mode 100644
index 0000000..94c9f7d
--- /dev/null
+++ b/dev-tex/mathpartir/Manifest
@@ -0,0 +1,3 @@
+DIST mathpartir.tgz 325049 SHA256 2697072b6615ced3601e9596f45507a199565078c67eff465e21e2d3c5b91bfe SHA512 fec136cf9acc211ea2c8e90bd458a1e316db9a8a62357e7cafbe9a321ca4800136a009adba10ed9fb5275f7af6bfefc1cd8ca85b848e22c0aa540892df753970 WHIRLPOOL 4ee5a4858cb49f966f34bbd7e0cfc1af5e0d94f417fabec4e1f8d5a433e4f3cd0e1f167ecf420c7380e0c75656ba2325dd5ea1daafcbe4ed3d53cf46f7efe1f7
+EBUILD mathpartir-1.2.0-r1.ebuild 909 SHA256 9495e4bdc532845663add3825720d82b8cf9f9a5a1105ab1eb8869ba8c49b343 SHA512 d6b1894f63ffd86e7535c2ed181d51b55fd4860bcf6e82c86bdda90977f3b7f74939ac027f4805b37879b60a45eb9ce9450834645124660fb29fbe6f5c0ecf3f WHIRLPOOL a5df0b073c80b62d23c53aa47b212aa1ca396876c433e73b4dde494f768c8693f888caa4f103f2b0e6f81b65d4a6073cd1617007255a73cd4611f16d611189a3
+MISC metadata.xml 1254 SHA256 6b2bb55730c2bf38199324089eea2e4c030a184df3e42dc6345864d53a1315ac SHA512 549565fee446f857d79fa79d881b8fb0141808047131bb5de86eb5db88d3200cafbccb5082f778362da7f59451fac940c21674f90a42754819f9880ebe218ca4 WHIRLPOOL 5e2bbfa1fc16f9f77ba2c9393ea10642dbaacd071498821c612ea69ace1b9550ed5b081f8f3e48d1a202ad82e378720cfe411bb5588ea3c6f0d7a22bfdf8703d
diff --git a/dev-tex/mathpartir/mathpartir-1.2.0-r1.ebuild b/dev-tex/mathpartir/mathpartir-1.2.0-r1.ebuild
new file mode 100644
index 0000000..fd0e91e
--- /dev/null
+++ b/dev-tex/mathpartir/mathpartir-1.2.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2013 Quentin Heath
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+SLOT="0"
+
+DESCRIPTION="LaTeX macros for typesetting inference rules"
+HOMEPAGE="http://cristal.inria.fr/~remy/latex/"
+SRC_URI="http://cristal.inria.fr/~remy/latex/${PN}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-text/texlive[extra] dev-tex/hevea )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+
+#pkg_setup()
+
+#src_unpack()
+
+#src_prepare()
+
+#src_configure()
+
+#src_compile()
+
+src_test() {
+ true
+}
+
+src_install() {
+ dodoc mathpartir.ps.gz mathpartir.pdf mathpartir.html
+ insinto /usr/share/texmf/tex/latex/${PN}
+ doins mathpartir.sty
+ insinto /usr/share/doc/texmf/latex/${PN}
+ doins mathpartir.tex mathpartir.dvi
+}
+
+#pkg_preinst()
+
+pkg_postinst() {
+ mktexlsr /usr/share/texmf
+}
+
+#pkg_prerm()
+
+pkg_postrm() {
+ mktexlsr /usr/share/texmf
+}
+
+#pkg_config()
diff --git a/dev-tex/mathpartir/metadata.xml b/dev-tex/mathpartir/metadata.xml
new file mode 100644
index 0000000..a193c4e
--- /dev/null
+++ b/dev-tex/mathpartir/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription>
+ This package provides macros for displaying lists of formulas
+ that are typeset in mixed horizontal and vertical modes.
+ The package is two-folded.
+
+ The first part is an environment mathpar that generalizes the math
+ display mode to allow several formulas on the same line, and several
+ lines in the same display. The arrangement of the sequence of formulas
+ into lines is automatic depending on the line width and on a minimum
+ inter-formula space and line width alike words in a paragraphs (in
+ centerline mode). A typical application is displaying a set of type
+ inference rules.
+
+ The second par is a macro inferrule to typeset inference rules
+ themselves. Here again, both premises and conclusions are presented as
+ list of formulas that should be displayed in almost the same way, except
+ that the width is not fixed in advance; and the inference rule should
+ use no more width than necessary so that other inference rules are given
+ a chance to appear on the same line.
+ </longdescription>
+ <upstream>http://cristal.inria.fr/~remy/latex/</upstream>
+</pkgmetadata>