summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2010-01-19 13:49:12 -0500
committerRussell Harmon <russ@eatnumber1.com>2010-01-19 13:52:43 -0500
commit4bcf9ec61da58eae7cee4c7a18f988ef45f96b13 (patch)
tree73d09ef4053b5e85a641204e71b17d98314d6fb7
parentRecover state of old repository before corruption. (diff)
downloadeatnumber1-4bcf9ec61da58eae7cee4c7a18f988ef45f96b13.tar.gz
eatnumber1-4bcf9ec61da58eae7cee4c7a18f988ef45f96b13.tar.bz2
eatnumber1-4bcf9ec61da58eae7cee4c7a18f988ef45f96b13.zip
Use raw ldflags in pidgin-omegle-scm
-rw-r--r--x11-plugins/pidgin-omegle/files/pidgin-omegle-scm_Makefile.patch6
-rw-r--r--x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild3
2 files changed, 5 insertions, 4 deletions
diff --git a/x11-plugins/pidgin-omegle/files/pidgin-omegle-scm_Makefile.patch b/x11-plugins/pidgin-omegle/files/pidgin-omegle-scm_Makefile.patch
index ee66301..f81cca7 100644
--- a/x11-plugins/pidgin-omegle/files/pidgin-omegle-scm_Makefile.patch
+++ b/x11-plugins/pidgin-omegle/files/pidgin-omegle-scm_Makefile.patch
@@ -9,8 +9,8 @@ Index: Makefile
+
+CFLAGS += `pkg-config --cflags pidgin`
+CFLAGS += `pkg-config --cflags json-glib-1.0`
-+LDFLAGS += `pkg-config --libs pidgin`
-+LDFLAGS += `pkg-config --cflags json-glib-1.0`
++LIBS := `pkg-config --libs pidgin`
++LIBS += `pkg-config --libs json-glib-1.0`
+
+OBJECTS=libomegle.o om_connection.o
+
@@ -19,7 +19,7 @@ Index: Makefile
+all: libomegle
+
+libomegle: $(OBJECTS)
-+ $(LD) $(LDFLAGS) $(OBJECTS) -shared -soname $@.so -o $@.so
++ $(LD) $(LDFLAGS) $(OBJECTS) -shared -soname $@.so -o $@.so $(LIBS)
+
+.c.o:
+ $(CC) -c $(CFLAGS) $< -o $@
diff --git a/x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild b/x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild
index 4f8d282..7e664bb 100644
--- a/x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild
+++ b/x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild
@@ -5,7 +5,7 @@
EAPI="2"
ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk/"
-inherit subversion toolchain-funcs multilib
+inherit subversion toolchain-funcs multilib flag-o-matic
DESCRIPTION="Omegle Plugin for Pidgin"
HOMEPAGE="http://code.google.com/p/pidgin-omegle/"
@@ -27,6 +27,7 @@ src_prepare() {
src_compile() {
tc-export CC LD
+ LDFLAGS="$(raw-ldflags)"
default
}