summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@howl.(none)>2008-06-10 00:17:46 -0400
committerroot <root@howl.(none)>2008-06-10 00:17:46 -0400
commitf8b5410769b83392791c4c2ac0ccd33c4580adc3 (patch)
tree168d48fe57cdedffbcbfb6cc46f01997f5addc79 /games-emulation
parentAdd fwnull svn ebuild. (diff)
downloadeatnumber1-f8b5410769b83392791c4c2ac0ccd33c4580adc3.tar.gz
eatnumber1-f8b5410769b83392791c4c2ac0ccd33c4580adc3.tar.bz2
eatnumber1-f8b5410769b83392791c4c2ac0ccd33c4580adc3.zip
Add spu2null svn ebuild.
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ps2emu-spu2null/ps2emu-spu2null-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-spu2null/ps2emu-spu2null-9999.ebuild b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-9999.ebuild
new file mode 100644
index 0000000..5885bbd
--- /dev/null
+++ b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="https://pcsx2.svn.sourceforge.net/svnroot/pcsx2/plugins/spu2/SPU2null"
+inherit eutils games subversion
+
+DESCRIPTION="PS2Emu null sound plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+DEPEND=">=x11-libs/gtk+-2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PCSX2}/SPU2null"
+
+src_unpack() {
+ subversion_src_unpack
+ S="${S}/Src"
+ cd "${S}"
+
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/\bstrip\b/d' \
+ -e 's/-O[0-9]\b//g' \
+ -e 's/-fomit-frame-pointer\b//g' \
+ Makefile || die
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)/ps2emu/plugins"
+ doexe libSPU2null.so || die
+ use doc && dodoc ../ReadMe.txt Changelog.txt || die
+ prepgamesdirs
+}